[SOLVED] WebApp does forget category colors

Hi,

on webapp-3.4.2.1108+660-Ubuntu_16.04-all, all selected colors for item categories are immediately dismissed after closing the app, and all category labels become grey.

Never had this problem before.

Any hints?

Thx,
jacks

@jackson5 does this happen for all categories or only for ones you created during that particular session?

When creating a new category and assigning a color to it using the ‘Manage Categories’ dialog, do you get any errors in your browser console (usually accessible by pressing F12)?

It is for all categories. I’ve had something like 20 categories, and they are all grey now.

If I assign a new color to a category, there does not appear any error in the browser console window.

Thx,
jacks

Might be an issue with your persistent setting, could you check this on your server with e.g. pyko?

@marty: If you refer to a specific script, which one?

Maybe this ?
And if I use that, what is the risk of deleting the persistent settings?

Thx,
jacks

Nevermind, deleting the persistent settings did not help either.

Thx,
jacks

Maybe related to: https://jira.kopano.io/browse/KW-2213 ?
Otherwise please make a support ticket so we can have a look at your system.

Hello,

Have exactly the same problem, after last upgrade, the categories and their names are reset on the next connection to the WebApp. Even we recreate them, they get back to default after logout and login again. It was working perfectly till the upgrade of Kopano Kore 8.4.5 to 8.5.

My system : Ubuntu 16.04.01
Kopano Système Central: 8.5.0 (Entreprise version)
WebApp: 3.4.5.1202+46.1 (on a separate server)
Z-Push: 2.3.9+0-0 (on a separate server)

I have already open a ticket.

Regards.

@raphaël: Did they find a solution for your ticket?

Thx,
jacks

@jackson5 We are currently investigating an issue in Kopano Groupware Core related to categories that go missing after logout/login. Keep an eye on https://jira.kopano.io/browse/KC-1045.

@jackson5 said in WebApp does forget category colors:

@raphaël: Did they find a solution for your ticket?

Thx,
jacks

But it surely would help if you still remember the exact nightly version of core you encountered the issue with. (Less bisecting)

@fbartels: It must have been something before core-8.4.90.1448, but I cannot determine it exactly.

thx,
jacks

We encountered the same issue.

On 2 customer systems which were upgraded to 8.5.X

Debian 9 on all Systems
8.5.2 (not working)
8.5.4 (not working)
8.5.90 (testing machine not working either)

All were upgraded from 8.4.X have not tried a fresh install yet.

Seems to be a core issue so far as I was able to reproduce it.
No change when installing any webapp. If downgraded to 8.4 it works fine.

Categories are pretty much unusable for our customers. And of course it happened to those who need them…

As KW-2419 was closed, I can confirm that this problem is fixed in webapp-3.4.9.1299.

Thx,
jacks