KOE 1.4-200 unable to open shared folders



  • Hi,

    after installing KOE 1.4-200 I’m not able to add aditional shared folders as the name of the shared mailbox is not showing up when typing it in, it seems that the GAB get not resolved anymore.

    before I was using KOE 1.3-160 without problem

    rg
    Christian


  • Kopano

    Hello @externa1 ,

    thanks for your report. Sadly I am unable to reproduce this locally and can still open shared folders just fine.

    Some questions about your environment:

    • which version of z-push are you using?
    • is the gab still visible in Outlook?
    • there is a new button in the Kopano ribbon to resync the profile in general and the individual parts. Can you try to resync the gab from here? (this button was in the general settings before)


  • @fbartels

    Hi Felix,

    The Version of z-push is 2.3.7beta1+0
    It seems to be in combination with outlook 2013 as with outlook 2016 i did not have this
    I alos did a remove and recreate of the outlook profile - but same effect

    No the GAB is not visible on the OL2013 install

    Ok found follwing errors in koe log:

    2017/06/21 09:04:45.664 (10,): Trace: GAB: Exception determining sequence: System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    bei Acacia.Features.GAB.GABHandler.DetermineSequence()
    2017/06/21 09:04:45.664 (10,): Debug: ZPushLocalStore: Opening store with prefix “C:\Users\ck.CKC\AppData\Roaming\Kopano\Kopano OL Extension”\KopanoLocalFolders
    2017/06/21 09:04:45.664 (10,): Debug: ZPushLocalStore: No existing store found
    2017/06/21 09:04:45.664 (10,): Error: ZPushLocalStore: Exception: System.NotSupportedException: Das angegebene Pfadformat wird nicht unterstützt.
    bei System.Security.Permissions.FileIOPermission.EmulateFileIOPermissionChecks(String fullPath)
    bei System.IO.Directory.InternalCreateDirectoryHelper(String path, Boolean checkHost)
    bei Acacia.ZPush.ZPushLocalStore.OpenOrCreateInstance(IAddIn addIn)

    under C:\Users\ck.CKC\AppData\Roaming there is no Kopano folder present

    rg
    Christian


  • Kopano

    @externa1 did you change the location of this pst via the registry/plugindebugger? normally its located at AppData\Local\Kopano\Kopano OL Extension



  • @fbartels
    No I didn’t do this (but under local there is kopano folder) bevor there was 1.3-160 installed which worked

    I now uninstalled KOE and reinstalled but that did not help either

    rg
    Christian


  • Kopano

    @externa1 are you sure? your logging suggests otherwise.

    Do you have a registry key called LocalStorePath at HKEY_LOCAL_MACHINE\Software\Kopano\Kopano OL Extension? In a default installation this key does not exist. if this key is not found or empty KOE will fall back to %LocalAppData%\Kopano\Kopano OL Extension and otherwise use the location set in LocalStorePath.

    Another thing would be to manually create the path KOE complains about not being able to create. but to my knowledge KOE should normally create it, it its not found already.



  • @fbartels

    No there is no such registry entry
    0_1498036184348_29db0ad9-53ff-4f72-9231-3fd1440ece85-grafik.png

    I already created the path manually but that also did not change the error

    rg
    Christian


  • Kopano

    @externa1 can you post which directory you get, if you paste %localappdata% into the windows explorer?



  • @fbartels

    seems correct as i got : C:\Users\ck.CKC\AppData\Local

    rg
    Christian


  • Kopano

    @externa1 thats really weird? did there have been any attempts on that specific machine to configure roaming profiles in the past?

    Does it work if you create the registry key to point to %LocalAppData%\Kopano\Kopano OL Extension?



  • @fbartels

    Do you have a registry key called LocalStorePath at HKEY_LOCAL_MACHINE\Software\Kopano\Kopano OL Extension?

    No but there was LocalStorePath at HKEY_CURRENT_USER\Software\Kopano\Kopano OL Extension

    Don’t know how this came there but after deleting the key and reinstall KOE all worked

    rg
    Christian


  • Kopano

    @externa1 good to hear that you found the reason.



  • Hello,

    If you read the carefully, you will find this:

    2017/06/21 09:04:45.664 (10,): Debug: ZPushLocalStore: Opening store with prefix “C:\Users\ck.CKC\AppData\Roaming\Kopano\Kopano OL Extension”\KopanoLocalFolders
    

    take a look at the quotation marks… - I bet in this registry key was something like this:
    "%appdata%\Kopano\Kopano OL Extension” (with quotes)

    should work without this marks :) - but since its already solved for you, just want to mention this :)

    Coffee_is_life


Log in to reply