Z-Push Autodiscovery with local part != username



  • Not sure if this belongs to this forum:
    I have a server with some ldap users (login attribute is sAMAccountName).

    My problem is:
    When trying to setup Z-Push Autodiscover for Outlook, it doesn’t work as the local part of the address and login are not identical:
    sAMAccontName is the first character of given name and surname (for example “pbeck” for Peter Beck). but the local part of the mail is peter.beck.

    Outlook pops up with a credential window, but if I enter the correct username (p.beck) / password, i got following log entries:

    [WARN] [unknown] The local part of the server auth user is different from the local part in the XML request ('p.beck' != 'pbeck')
    

    When setting up an account without autodiscover and just enter the username and password, it just works, but it would be convenienant if autodiscover would do everything ;-)

    Is there any way to bypass this behavouir ?
    Or is it safe just to change the lpad_login attribute in the server config ? (maybe to “mail” and then change to full mail login in autodiscover)



  • We have the same problem. I opened already a ticket at Kopano, but they told me that’s actually not possible.
    This change would make the mobile device management easier. Perfect would be an additional IP geo-location option to allow different z-push target servers, depending on the country.


  • Kopano

    I think we can actually change this behaviour. A ticket was created with target Z-Push 2.3.7.
    https://jira.z-hub.io/browse/ZP-1231


  • Kopano

    Hi petervbeck, hi eli,

    After some investigation I must say that unfortunately there’s nothing we can do if the login name doesn’t match the local email part. For the pop-up credential window Outlook expects an exchange server behind, not an ActiveSync service account. In such cases only manual account config is possible.

    @eli said in Z-Push Autodiscovery with local part != username:

    We have the same problem. I opened already a ticket at Kopano, but they told me that’s actually not possible.
    This change would make the mobile device management easier. Perfect would be an additional IP geo-location option to allow different z-push target servers, depending on the country.

    You could open a feature request for geo-location option with kopano.

    Manfred



  • Hi Manfred,

    what about the mobile devices? autodiscovery can not be used for them, as long as there is no option to change the login attribute

    Guido


  • Kopano

    Hi Guido,

    a workaround would be to use loginname@domain and to make sure that USE_FULLEMAIL_FOR_LOGIN is set to false in both autodiscover and Z-Push main config. This way Z-Push will be able to login with your username. This workaround should work for both Outlook and mobile devices.
    In the autodiscover response Z-Push will send the correct email address of the user as it will get it from the Kopano. However I don’t know if the devices will use the correct email address in the account settings or the one you’ve provided when setting up the account.

    Manfred


  • Kopano

    Even if the email address is not showing correctly on the devices, the correct email address will be set when sending emails from any activesync client.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.