Webapp - Apache Basic-Auth



  • Hi!

    I am using ZCP for years and I am trying to migrate to Kopano, but there is one problem, I could not solve.

    I am using short-time passwords to access Webaccess from external devices. In the past, I was just using a .htaccess-file in a second webapp instance:

    .htaccess:

    #SSLRequireSSL
    AuthUserFile /var/www/webapphttps/.htpasswd
    AuthGroupFile /dev/null
    AuthName "Safety First"
    AuthType Basic
    <Limit GET>
    require valid-user
    </Limit>
    

    …and in server.cfg:

    local_admin_users       = root vmail www-data kopano
    

    With webaccess 2, that was possible, but now, there is just and endless “loop” with the Kopano logo instead of a login.

    Can you give me a hint on what I could try?

    Thank you
    Regards,
    Stril


  • Kopano

    Hello @Stril ,

    one word of advice: giving your webserver admin permissions in Kopano is not really “safety first”.

    I’d rather recommend to create a client ssl certificate and specifically authenticate webapp with this one.

    That said I don’t think i don’t think the loop is because of the auth. you should check your browsers error console for some additional hints. maybe @marty has some more ideas here then.



  • Hello!

    Thank you for your answer.

    I started the browser console. I can only see one message after some seconds:

    VM42 kopano.js?version=3.4.0.764-0+517.1:158 POST http://IP-ADDR/webapphttps/kopano.php?subsystem=webapp_1500930205177 401 (Unauthorized)

    Do you have any idea, why there is “Unauthorized” after the successful auth? Apache Log shows the right username…

    Regards,
    Stril


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.