php-curl not available with webapp files-plugin



  • Hi everybody,

    I have newly upgraded my old zarafa installation to kopano on Debian 9.0.
    Today I tried to activate the files plugin, but when I try to setup up my owncloud account it stays offline and tells that php-curl is not available. But in fact I have php-curl and php7.0-curl installed (on debian 9.0 php7 is used). The phpinfo tells me that curl is loaded.

    /etc/php/7.0/mods-available/curl.ini

    ; configuration for php curl module
    ; priority=20
    extension=curl.so
    

    cat -n /etc/php/7.0/apache2/php.ini | grep extension_dir

     ; extension_dir = "./"
      ; extension_dir = "ext"
      ; Be sure to appropriately set the extension_dir directive.
      ;sqlite3.extension_dir =
    

    Hope that anybody can help.

    Thanks in advance!


  • Kopano

    Could you double check if the module is enabled? Maybe activate it with a2enmod.



  • Hi,

    thanks for your answer. I tried that, but could´t find any module named curl.

    a2enmod curl
    ERROR: Module curl does not exist!
    

    any other variants didn´t worked aswell (php-curl, php7-curl…)


  • Kopano

    Ah yeah I have that same problem on my debian9 machine.
    But my curl extension is actually loaded.

    Do you have the file
    /etc/php/7.0/apache2/conf.d/20-curl.ini

    and did you restart apache after installing the module?



  • yes, this files exists with the following content:

    ; configuration for php curl module
    ; priority=20
    extension=curl.so
    
    


  • also restarted apache of course ;)


  • Kopano

    Since you’ve upgraded jessie to stretch a new php version (7) is also installed.
    Please double check if php5 is not used (Can be checked in phpinfo).

    For example:
    Configuration File (php.ini) Path should be “/etc/php/7.0/apache2”



  • Hi Marty,

    everything seems to be on php7.

    0_1499775616069_php_info.PNG


  • Kopano

    btw, could you paste your versions of kopano and mapi:
    dpkg -l | egrep ‘kopano|mapi’



  • Hello,

    I’ve come across the same issue and I’m hoping someone figured t his out already. If so could you post the fix?

    a2enmod curl is failing even though curl 7.48 shows as enabled in php (via info.php printout) because there is not a curl.load file in the /etc/apache2/mods-available folder.

    I do find curl.so in /usr/lib/php/20151012/curl.so
    And there are two 20-curl.ini files:
    /etc/php/7.0/apache2/conf.d/20-curl.ini
    /etc/php/7.0/cli/conf.d/20-curl.ini

    I suspect that somewhere there should be a curl.load file generated by some app durring Kopano php install.
    I’ve been looking on line for hours and nothing about how to generate the file manually.
    Also, apt-get remove curl and reinstall does not help

    How to proceed? Any help would be greatly appreciated.

    Thanks


Log in to reply