Files-Plugin causes problems



  • Unfortunately I have a big problem with the now delivered Files plugin.

    All users get an “unexpected error” as popup from Kopano every time they start the WebApp or DeskApp (so no Windows error)

    If you reset the settings of the plugin and delete all accounts the error is gone. If you add a SMB drive it will take a few minutes until you see the files. I can’t mount more than two SMB drives now. If I try to mount more than two SMB drives, I get the “unexpected error” again and only the drives are displayed, but not their contents.

    Also, after logging in to the web app, I can only access the contents of mails after about 30 seconds or after the “unexpected error” has occurred. Before that only the subject is displayed.

    Only if I leave the plugin unused does the WebApp work without delays and errors.


  • Kopano

    Hi @bitboy0,

    please specify the versions of all software involved (os of server, webapp, files plugin, …).

    I have move your post to the webapp plugin section.



  • WebApp:4.0.2740+113.1
    Kopano Core:8.7.12
    Z-Push:2.5.2+0-0
    Files-Plugin 2.1

    Server UCS 4.4.4 errata613



  • @bitboy0 said in Files-Plugin causes problems:

    unexpected error

    Had the same problem on my server (UCS 4.4-4 errata613). With every login I got the message “unexpected error”.

    After I reset the account settings of the Files-Plugin the message was gone.

    I can add more than two accounts (SMB) without problems. But it also takes some seconds until the content of the new account is displayed. During this time no other data (e.g. emails, calendar, …) will be displayed. The Apache2 process consumes about 35% CPU load during this time. Probably necessary to build the cache.

    WebApp: 4.0.2740+113.1
    Kopano Core: 8.7.12
    Z-Push: 2.5.2+0-0
    Files-Plugin: 3.0.0.0+118.3
    Filesbackend-SMB-Plugin: 3.0.0.0+36.3



  • The new Kopano Webapp is severly broken if big external storages are attached in the “files” view. Then the Apache error log is filled up with log messages indicating that it tries to add all files to a cache:

    Fri May 22 00:17:45.846777 2020] [:error] [pid 2727] [client 192.168.1.166:42594] [DBG][FilesListModule] Getting cache for node: 49eb6ce2ae933880f6fe61cc9e626db3/install/portableapps/PortableApps/XAMPP/App/xampp/mysql/backup/test ## user499ebe01e61bbab09703fc6a8bb5899f, referer: https://192.168.1.88/webapp/

    This breaks the webapp heavily by making it extremely lagging. The storage configured in the settings menu cannot be removed because of this lag, the temporary files in /var/lib/kopano-webapp/tmp have to be deleted to make the webapp working again. If a storage (SMB/Nextcloud) is added, the problem persists. Only removing all external storage from the webapp for now works.


  • Kopano

    @bitboy0 @Martin @e-alfred

    It seems that something went wrong with uploading the package to univention, but this will be fixed asap.

    In the meantime you can do:



  • @Martin said in Files-Plugin causes problems:

    Files-Plugin: 3.0.0.0+118.3

    Many thx to @marty for your fast response.

    I switched to pre-final, re-mounted all accounts and now everything is working fine again.

    Best regards
    Martin



  • @Martin said in Files-Plugin causes problems:

    After I reset the account settings of the Files-Plugin the message was gone.

    Yes, same here.



  • @marty download.kopano.IO was the better link ;)

    Thanks anyway!

    Now I don’t know how to install this …



  • Okay, did it … changing resporitory temporary to “pre” and then apt-get upgrade …
    Works fine again now.



  • @fbartels This is still not fixed on Kopano4UCS.



  • I just signed up again here to report, that kopano through UCS have delivery again faulty plugins.

    My native Ubuntu system with kopano repo delivered:

    ii kopano-webapp-plugin-files 2.1.5.305+101.1

    UCS however delivers:

    kopano-webapp-plugin-files 3.0.0.0+118.3

    What did i do to downgrade?

    Check available package versions with

    apt-cache show PACKAGENAME

    and then downgrade with

    apt-get install PACKAGENAME=VERSION

    apt-get install kopano-webapp-plugin-files=2.1.5.305+101.2
    apt-get install kopano-webapp-plugin-filesbackend-smb=2.1.0.50+31.5

    After downgrade, all my files / folders came back and issues are gone.

    @fbartels - just to make sure - yes we have and had FINAL release selected and not any bloody beta or whatever:

    2c5d0927-b849-44e2-addc-b0ce2a558f5f-grafik.png


  • Kopano

    @e-alfred yes. as communicated in https://help.univention.com/t/kopano-broken-after-todays-update-to-webapp-version-3-5-14-2539/15113/15?u=fbartels I have uploaded a new version to the Univention appcenter and am currently waiting for Univention to make this new version public (I am in contact with them about it).


Log in to reply