Outlook not syncing a specific folder



  • So we have a couple users (but I will focus on one for now) where when they try to use Outlook as a client (with KOE) it refuses to sync at least one specific folder!
    I’m placing this in the KOE section because this user’s folder does so on her phone.

    The user has Outlook 16 with KOE 1.3 and no matter what I try when I look at the details of the user:

    kopano-activesync:~# z-push-admin -a list -u castrof -d d0ff2884765d4badbabea513be4d9ef5
    
    Synchronized by user: castrof
    -----------------------------------------------------
    DeviceId:		d0ff2884765d4badbabea513be4d9ef5
    Device type:		WindowsOutlook
    UserAgent:		Outlook/16.0 (16.0.4266.1001; MSI; x86)
    ActiveSync version:	14.0
    First sync:		2017-05-12 10:48
    Last sync:		2017-05-16 15:45
    Total folders:		17
    Short folder Ids:	Yes
    Synchronized folders:	12 (2 in progress)
    Synchronized data:	GAB Emails(7) Contacts Calendars Notes Tasks 
    Synchronization progress:
    	Folder: Sent Items           Sync: Initialized   Status:  0% (0/151)
    	Folder: Debs                 Sync: Initialized   Status:  0% (0/1)
    Additional Folders:	none
    Status:			Not available
    WipeRequest on:		not set
    WipeRequest by:		not set
    Wiped on:		not set
    Policy name:		default
    Kopano Outlook Extension:
    	Version:	1.3.156
    	Build:		343705345b7aef675e2e0a1aa37d011171b6cf2f
    	Build Date:	2017-04-05 12:11
    	Capabilities:	receiveflags,sendflags,oof,ooftime,sharedfolders,webapp,freebusy,gab,notes,secondarycontacts,sendas,signatures,debugsupport
    Attention needed:	Invalid states. Please force synchronization!
    

    I have tried full resyncs, prayer, deleting the OST file, virgin sacrifice, clearloops, I have even found the Folder IDs (using a python script) of the problem folders and tried to resync just them… Nothing works!

    Any ideas?
    Thanks
    Bob


  • Kopano

    How does it look for the user? Is the Sent Items folder empty? Is the issue with the Sent Items folder?

    We are going to need more detailed logs:

    • enable wbxml logging mode for this user (by adding the username to $specialLogUsers)
    • perform a “z-push-admin -a clearloop”
    • try to resynchronize this folder using the folderid (as you already tried)
    • let OL synchronize for some time
    • send us the log (preferably via a support ticket - reference this thread please)

    What does Outlook do in this period? Is it saying “connected”, “disconnected”, “downloading from server” or “Updating Folder XXX” (all this in the status line in the bottom of OL).
    We have seen similar behaviour with appointments, where OL got stuck on “Updating Calendar” and basically never did anything else.

    Cheers,
    Sebastian



  • I thought you might have wanted the WBXML logs, so I enabled them last night.

    Well there is a folder called Debs which isn’t syncing, but I think it is because it is stuck in the queue behind "Sent Items"
    I already tried the clearloop option a few times and letting OL sync overnight did nothing.
    Outlook itself is “Connected” but is always sitting there with a "Waiting for Server Response…

    So I can’t attach a file or use more then XXXXX many characters, so I’ll upload the file I have via a support ticket.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.