Can't get web meetings up and running



  • Hi to all,
    I’m stuck at the same point mentioned in this old post: https://forum.kopano.io/topic/385/webmeetings-never-initializes/11.
    Since this questioned never was solved, I assume that this problem is hard to comprehend.
    To get it to the point, I inserted in my /etc/kopano/webmeetings.cfg:

    [log]
    logfile = /var/log/kopano/webmeetings.log
    log_level = 6
    

    but all that is logged is (after service restart)

    server 2018/10/01 10:05:26 Got signal 15, stopping all services
    server 2018/10/01 10:05:26 Stopped HTTPS server on 127.0.0.1:8090
    server 2018/10/01 10:05:26 Using '/webmeetings/' base base path.
    server 2018/10/01 10:05:26.157821 Enabled modules: [roomlocking screensharing youtube presentation]
    server 2018/10/01 10:05:26.162299 Using the number of CPU's (1) as GOMAXPROCS
    server 2018/10/01 10:05:26.162327 Max open files are 1024
    server 2018/10/01 10:05:26.163608 Enabled users handler 'sharedsecret'
    server 2018/10/01 10:05:26 Starting HTTP server on 127.0.0.1:8090
    

    Server and client are in the same network, thus no turn server takes part in the communication.

    In Webmeetings.cfg, I set different 32-Byte-Hex-values for session secret, encryption secret and server secret. In presence.cfg another server_secret_ key and brought them together in webapp/config-meetings.php like explains in the web meetings manual.

    /var/log/presence.log gives:

    2018-10-01 11:13:58,400 - presence - INFO - starting presence
    2018-10-01 11:13:58,433 - presence - INFO - spreed: plugin enabled
    2018-10-01 11:14:24,912 - presence - DEBUG - spreed: myuser@mydomain unavailable
    2018-10-01 11:15:27,958 - presence - DEBUG - spreed: myuser@mydomain available
    2018-10-01 11:16:31,010 - presence - DEBUG - spreed: myuser@mydomain available
    2018-10-01 11:17:34,059 - presence - DEBUG - spreed: myuser@mydomain available
    

    I tried both, nginx/apache- and apache-only-setup.

    So, is there any way to make webmeetings a bit more talkative? And: is there any deeper documentation than this one: https://documentation.kopano.io/web_meetings_manual/ ?

    Best regards

    Thomas


  • Kopano

    Hi @q5616417 ,

    @q5616417 said in Can't get web meetings up and running:

    I’m stuck at the same point mentioned in this old post

    and which exact error is that?

    From your posted logging I do not see an error? What exactly does not work? Which version of the stack are you using (core, webmeetings, webapp, …)?



  • Hi Felix,
    thank you for your reply. The “error” (if any) is, that the camera symbol in webapp stays grey. Further, when I click on the camera-symbol the window stays sort of empty, like shown in the screenshot.
    screenshot-webapp

    Opening the web meetings webpage directly (not out of webapp) shows the following:
    screenshot-webmeetings

    It won’t stop initializing the circle is turning around for ever and ever.

    kopano-cli -version says 8.6.80, webapp I installed from webapp-3.4.17.1594+910-Debian_9.0-all.tar and web meetings from webmeetings-0.29.5_1-Debian_9.0-amd64.tar.gz

    So, I don’t really know if that’s an error, but I would expect some functionality for creating a room or something.

    Best regards

    Thomas


  • Kopano

    Ah, he is failing at initialising. In that case you will find further details in the developer tools of your browser (javascript console and in the network tab).



  • Webdeveloper tools show

    SyntaxError: An invalid or illegal string was specified webapp_auth_api.php:191
    <anonym>
    https://servername/webapp/plugins/spreedwebrtc/php/webapp_auth_api.php:191:5
    

    Honestly, I don’t know what to do with this information. Do you know?



  • Previous post was the output given on the web meetings page. Webapp gives the following output:

    DOMException: "An invalid or illegal string was specified" main.js:43:9383
    o/<
    https://servername/webmeetings/static/ver=0295/js/main.js:43:9383
    nn/this.$get</<
    https://servername/webmeetings/static/ver=0295/js/main.js:42:27456
    a/<
    https://servername/webmeetings/static/ver=0295/js/main.js:43:16120
    $eval
    https://servername/webmeetings/static/ver=0295/js/main.js:43:23396
    $digest
    https://servername/webmeetings/static/ver=0295/js/main.js:43:21942
    $apply
    https://servername/webmeetings/static/ver=0295/js/main.js:43:23692
    u
    https://servername/webmeetings/static/ver=0295/js/main.js:42:31072
    b
    https://servername/webmeetings/static/ver=0295/js/main.js:43:1246
    dn/</S.onload
    https://servername/webmeetings/static/ver=0295/js/main.js:43:1792
    

  • Kopano

    Hi @q5616417 ,

    @q5616417 said in Can't get web meetings up and running:

    webapp_auth_api.php

    together with

    @q5616417 said in Can't get web meetings up and running:

    myuser@mydomain

    There was a report in the past here on the forum where a user also wanted to use a mail domain as a username. This is a scenario we do not test for in our tests/which we do not support. Does it make a difference if you use a simple username?



  • No, unfortunately no difference with “testuser”.



  • Is there possibly something missing in my php-setup? PHP-Version is

    PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
        with Zend OPcache v7.0.30-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies
    

  • Kopano

    Hard to say. I just rolled out a fresh installation with Debian 9 and the current master packages and here everything works out of the box.

    I would recommend to get in contact with our support so someone could have a direct look on your system.



  • Hi Felix,
    thank you for your work. Since I’m testing with community edition, is there any possibility to buy support services without subscription?


  • Kopano

    I’m sure we can make something happen there. Just drop an email to sales at kopano dot com.



  • Hi Felix,
    to bring this topic to an end: because you wrote, that everything is working fine for you, I did a fresh install on another machine and voilà - webmeetings is working and it looks very good :)
    So, thank you for your support.