unknown_transfer_encoding.bin

Hi,

I get following attached file[0_1515589899345_unknown_transfer_encoding.bin](Lade 100% hoch) instead of email (html) text in deskapp and webapp - in outlook (koe) and iphone the mail is displayed as html correctly

Here the view within outlook

![0_1515589962441_5a1af339-b4d6-4290-9972-5c2e8ab7c333-grafik.png](Lade 100% hoch)

Kopano Core 8.4.5.0
Webapp 3.4.4.1145+678.1
z-push 2.4.0.beta1+0.84c366b-0
KOE 1.6.264

rg
Christian

Hi @externa1 ,

it seems your uploads got lost somewhere along the lines.

Since a few days I see the same file “unknown_transfer_encoding.bin”, created by a Fujitsu Q902 NAS. This behavior started after upgrading the NAS box to current firmware. The file contains html code but misses the html header and footer. So I assume this is a bug in NAS firmware. Question is why Kopano 8.4.5.0-33.1 stores this file with an .bin extension?

What is the source of your mail?

My QNAP NAS TS453mini creates the same emails with attached file “unknown_transfer_encoding.bin” since one of the last firmware updates. Kopano Version 8.4.90.1427

Martin,

I forget to mention, Fujitsu NAS is a re-branded QNAP NAS.

As temporary fix, I set the mail to plain text.

Good idea, i also switched to plain text ;-)

@martin said in unknown_transfer_encoding.bin:

My QNAP NAS TS453mini creates the same emails with attached file “unknown_transfer_encoding.bin” since one of the last firmware updates. Kopano Version 8.4.90.1427

Could you provide a sample email? I would expect neither mime-type or filename is being set.

Bo

Hi,

this is the content of the “unknown_transfer_encoding.bin” file:

<div style="font-family:Verdana; width: 786px; height: 24px; background-color: #3977AA;">
	<table cellspacing="0" cellpadding="0" border="0" width="100%">
		<tr>
			<td align="middle" valign="middle"><span style="font-size: 12px; color: #ffffff;font-weight:bold;">Simple yet powerful NAS</span></td>
		</tr>
	</table>
</div>
<div style="font-family:Verdana; width: 786px; text-align: center; padding: 40px 0 0">
	<div style="width:680px; border:1px solid #dfdfdf; margin: 0 auto;">
		<div style="padding: 35px 60px;">
			<div style="font-size:18px; font-weight:bold; color:#2E2F30;">
				icc-nas Warning
			</div>
			<div style="margin: 18px 0 28px; width: 100%; height: 3px; background-color: #cecece;"></div>
			<div style="text-align:left; color: #010101; font-size: 12px; line-height: 24px;">
				<p>Server Name: icc-nas<br>IP Address: 192.168.130.6<br>Date/Time: 15.01.2018 06:50:43<br>Level:  Warning<br><br>[NAS_HOST: Drive 2] This drive is busy. Speed test is skipped.<p>
			</div>
		</div>
	</div>
	<div style="width: 680px; text-align: right; padding: 10px 0 0; border: 0; margin: 0 auto;">
		&nbsp;
	</div>
</div>

Hi Walter

@walterhof said in unknown_transfer_encoding.bin:

this is the content of the “unknown_transfer_encoding.bin” file:

Unfortunately you can only see the problem in the RFC2822 mail. If you have “imap”-feature enabled for the user, then you should be able to use the download EML feature in WebApp to get the original received email.

Bo

Sorry I can’t upload the eml file - not enough privileges error.
So here the eml file as code:

Return-Path: <icc-nas@hofstaedtler.com>
Received: from icc-zarafa.hofstaedtler.local ([::ffff:127.0.0.1]:33386) by
 icc-zarafa (kopano-dagent)  with LMTP; Mon, 15 Jan 2018 06:50:44 +0100
Received: from icc-nas (icc-nas.hofstaedtler.local [192.168.130.6])  by
 icc-zarafa.hofstaedtler.local (Postfix) with SMTP id B34D865 for
 <monitor@hofstaedtler.com>; Mon, 15 Jan 2018 06:50:43 +0100
Received: by icc-nas (sSMTP sendmail emulation) ; Mon, 15 Jan 2018 06:50:43
 +0100
Subject: icc-nas Warning
From: =?utf-8?Q?icc-nas?= <icc-nas@hofstaedtler.com>
To: =?utf-8?Q?Monitor?= <monitor@hofstaedtler.com>
Date: Mon, 15 Jan 2018 05:50:43 +0000
Mime-Version: 1.0
Content-Type: application/octet-stream; 
 name=unknown_transfer_encoding.bin
Content-Transfer-Encoding: base64
Content-Disposition: attachment; 
 filename=unknown_transfer_encoding.bin

DQo8ZGl2IHN0eWxlPSJmb250LWZhbWlseTpWZXJkYW5hOyB3aWR0aDogNzg2cHg7IGhlaWdo
dDogMjRweDsgYmFja2dyb3VuZC1jb2xvcjogIzM5NzdBQTsiPg0KCTx0YWJsZSBjZWxsc3Bh
Y2luZz0iMCIgY2VsbHBhZGRpbmc9IjAiIGJvcmRlcj0iMCIgd2lkdGg9IjEwMCUiPg0KCQk8
dHI+DQoJCQk8dGQgYWxpZ249Im1pZGRsZSIgdmFsaWduPSJtaWRkbGUiPjxzcGFuIHN0eWxl
PSJmb250LXNpemU6IDEycHg7IGNvbG9yOiAjZmZmZmZmO2ZvbnQtd2VpZ2h0OmJvbGQ7Ij5T
aW1wbGUgeWV0IHBvd2VyZnVsIE5BUzwvc3Bhbj48L3RkPg0KCQk8L3RyPg0KCTwvdGFibGU+
DQo8L2Rpdj4NCjxkaXYgc3R5bGU9ImZvbnQtZmFtaWx5OlZlcmRhbmE7IHdpZHRoOiA3ODZw
eDsgdGV4dC1hbGlnbjogY2VudGVyOyBwYWRkaW5nOiA0MHB4IDAgMCI+DQoJPGRpdiBzdHls
ZT0id2lkdGg6NjgwcHg7IGJvcmRlcjoxcHggc29saWQgI2RmZGZkZjsgbWFyZ2luOiAwIGF1
dG87Ij4NCgkJPGRpdiBzdHlsZT0icGFkZGluZzogMzVweCA2MHB4OyI+DQoJCQk8ZGl2IHN0
eWxlPSJmb250LXNpemU6MThweDsgZm9udC13ZWlnaHQ6Ym9sZDsgY29sb3I6IzJFMkYzMDsi
Pg0KCQkJCWljYy1uYXMgV2FybmluZw0KCQkJPC9kaXY+DQoJCQk8ZGl2IHN0eWxlPSJtYXJn
aW46IDE4cHggMCAyOHB4OyB3aWR0aDogMTAwJTsgaGVpZ2h0OiAzcHg7IGJhY2tncm91bmQt
Y29sb3I6ICNjZWNlY2U7Ij48L2Rpdj4NCgkJCTxkaXYgc3R5bGU9InRleHQtYWxpZ246bGVm
dDsgY29sb3I6ICMwMTAxMDE7IGZvbnQtc2l6ZTogMTJweDsgbGluZS1oZWlnaHQ6IDI0cHg7
Ij4NCgkJCQk8cD5TZXJ2ZXIgTmFtZTogaWNjLW5hczxicj5JUCBBZGRyZXNzOiAxOTIuMTY4
LjEzMC42PGJyPkRhdGUvVGltZTogMTUuMDEuMjAxOCAwNjo1MDo0Mzxicj5MZXZlbDogIFdh
cm5pbmc8YnI+PGJyPltOQVNfSE9TVDogRHJpdmUgMl0gVGhpcyBkcml2ZSBpcyBidXN5LiBT
cGVlZCB0ZXN0IGlzIHNraXBwZWQuPHA+DQoJCQk8L2Rpdj4NCgkJPC9kaXY+DQoJPC9kaXY+
DQoJPGRpdiBzdHlsZT0id2lkdGg6IDY4MHB4OyB0ZXh0LWFsaWduOiByaWdodDsgcGFkZGlu
ZzogMTBweCAwIDA7IGJvcmRlcjogMDsgbWFyZ2luOiAwIGF1dG87Ij4NCgkJJm5ic3A7DQoJ
PC9kaXY+DQo8L2Rpdj4NCg==

Download with Deskap.

Walter

@walterhof said in unknown_transfer_encoding.bin:

Content-Type: application/octet-stream;
name=unknown_transfer_encoding.bin
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename=unknown_transfer_encoding.bin

That seems, unfortunately, to be the generated email and not the original one. :/ so not much to see.

Bo

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.