[Solved] Migrating zarafa to kopano



  • Hi,
    we are migrating zarafa 7.1 (on CentOS 6) to kopano on a new CentOS 7 machine. After the sync of database and attachments we run kopano-server -F --restart-searches as described here:
    Re: Server.log - Error setSyncStatus(): collision
    But we still get those [error ] setSyncStatus(): collision messages in the server.log.
    Is there a solution for that problem?

    Best regards
    Achim



  • hi @afischer ,
    could you give us some more infos? Are any other erros in the logfiles? is the server running correctly?

    Did you read the steps for Migration from 7.1. to kopano?
    https://documentation.kopano.io/kopano_migration_manual/zcp_migration.html#manual-zcp-to-kopano-migration
    to which KC Version did you migrate?
    What do you mean with “After Sync of databases and attachments” ? Did you copy it to a new machine?
    best regards
    Andreas



  • Hi Andreas,
    thanks for your reply.
    No, there are no other errors. These entries show up every 9 minutes:

    Tue Dec 12 08:50:23 2017: [error  ] setSyncStatus(): collision
    Tue Dec 12 08:59:17 2017: [error  ] Previous message logged 100 times
    Tue Dec 12 08:59:17 2017: [error  ] setSyncStatus(): collision
    Tue Dec 12 09:08:10 2017: [error  ] Previous message logged 100 times
    

    Yes, we read the steps for migration.
    Yes, we copied the database and attachments fom our old ZCP-Server (7.1.13 on CentOS 6) to our the KC-Server (8.3.4 CentOS 7). So we can test the new server.
    The KC-Server is working so far.

    Best regards,
    Achim



  • Hi Achim,
    I just found this about your topic:
    https://forums.zarafa.com/showthread.php?11854-Errors-in-server-log-after-Migration-to-other-Hardware
    Felix suggestet this:
    "This error pops up, when the internal searchfolders have gotten out of sync. To repair you have to stop zarafa-server and start it once with the parameter “–restart-searches” (it will afterwards start automatically again and I would recommend to stop it manually and start via init afterwards). "
    Hope this helps.
    Best regards
    Andreas



  • Hi Andreas,
    many thanks for your effort. I found this solution, too - but it doesn’t help.
    I think I found the reason and a solution for those error messages.
    As I wrote, we set up a new machine. Then we stopped all services on the old one, synced database and attachments and did the rest of the migration process. While we were testing kopano our live-system remains the old ZCP. A week later or so we did another test-migration. The problem is, that kopano had built up the new search-index meanwhile. A rm -Rf /var/lib/kopano/search/* before the migration solved the problem.

    Best regards,
    Achim


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.