[Solved] Outlook can't open Kopano.ost after login on seconde pc



  • Hi at all,

    this weekend I migrated from Zarafa to Kopano on UCS. Kopano you made and documented a great job. Thanks.

    The sync on all client machines is done. But on on pc Outlook 2016 can’t open the user ost file after this domain user logged in second pc. The error message is:

    ---------------------------
    Microsoft Outlook
    ---------------------------
    Microsoft Outlook kann nicht gestartet werden. Das Outlook-Fenster kann nicht geöffnet werden. Diese Ordnergruppe kann nicht geöffnet werden. Auf die Datei "C:\Users\<user>\AppData\Local\Microsoft\Outlook\<email>@<domain> - Kopano.ost" kann nicht zugegriffen werden. Sie wurde für die Verwendung mit einem anderen Postfach konfiguriert.
    ---------------------------
    OK   
    ---------------------------
    

    My software versions are as followed
    Univention server:

    UCS: 4.2-3 errata231
    App Center compatibility: 4
    Installed: cups=1.7.5 dhcp-server=11.0.0 kopano-core=8.3.1.32 kopano-webapp=3.3.0.610 nagios=3.5 pkgdb=10 samba4=4.6 squid=3.4 z-push-kopano=2.3.7
    Upgradable:
    

    Windows-Client

    Windows 7 Prof
    Client: Kopano OL Extension 1.5.240
    

    Both pc’s are domain members and the user is the same domain user. The files on both pc’s where with the same size down to the kilobyte.

    At the moment I deleted the Outlook-Profile on the first pc an created it again, so the ost file was rebuilded.

    What do I have to configure, so I can use outlook via Z-Push on both pc’s?

    Thanks
    Ulf


  • Kopano

    Hi @BusinessTux ,

    glad to hear you like it. To me, this sounds like you are using roaming profiles or using an OST at a shared location (like a network drive) - Is that correct? If so, I strongly recommend you to choose a different location of the ost file at profile creation time because otherwise the OST is per default part of the roaming profile which is synced and that would not work for the same user on 2 PC’s.

    The limitation that OST-files cannot be used in parallel is a limitation of Outlook, and not Kopano. Sorry to say so … ;)



  • Hi mkromer,

    thanks. Yes, I use roaming profiles for the users. But the ost file is only on the local appdata-path of the user profile:

    C:\Users\<user>\AppData\Local\Microsoft\Outlook\
    

    So the ost file is located locally on both machines.

    PS:
    Only 3 minutes reaction time. GREAT.


  • Kopano

    Hi @BusinessTux,

    well … I see, the profile is configured, but the OST file is missing from the second PC whereas outlook expects it to be there. Thats kind of <cencored> ;)

    So, OST files and roaming profiles are (designed by MS) mutually exclusive… Also for a very long time already, as you can see here: https://social.technet.microsoft.com/Forums/windowsserver/de-DE/494cfd50-2a65-46eb-b66c-d89eac77fecf/outlook-ost-and-roaming-profiles-?forum=winserverGP or also here: https://support.office.com/en-gb/article/Find-and-transfer-Outlook-data-from-one-computer-to-another-0996ece3-57c6-49bc-977b-0d1892e2aacc#ID0EAACAAA=2016,_2013

    I’m personally not an expert on Windows in combination with roaming profiles, but I would really check to see if you could maybe apply an exclusion also for the Outlook Roaming part which also stores the configuration data, e.g. using something like HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\ExcludeProfileDirs (or alternatively with gpedit.msc at the following location: User Configuration\Administrative Templates\System\User Profiles\Exclude directories) for that.

    The downside is you would need to configure the profile twice but you should be able then to at least configure the 2 profiles on both PCs without them to conflict with each other.

    Hope this helps.

    mike



  • Hi Michael,

    ok, I will check this. I have already some exclusions for Thunderbird via GPO. I will extend it to the Outlook path and report my result.

    Thanks
    Ulf



  • Hi Michael,

    I’ve configured AppData\Roaming\Microsoft\Outlook via GPO as exception and it is not synced to the profile data on the server. But the error occurs again. After starting Outlook on the the second pc with the same user I get error message from above on the first pc.

    How can I use it on both pc’s? Only without server profiles?

    Thanks
    Ulf



  • Hello!

    I also tried to configure roaming profiles to work with Kopano (see https://forum.kopano.io/topic/99/outlook-with-roaming-profile-on-different-computers)

    What I can say so far

    • when using KOE you should use the PluginDebugger.exe to set the location of the Kopano.pst to the roaming folder so that it gets synced between the clients. Otherwise Outlook fails to start as soon as it was configured on an other computer and connot find the pst file

    But there are some other things that make it almost unusable:

    • Outlook and even the Windows 10 Mail-and-Calendar app store the Device ID in the “current user” registry part. So when using roaming profiles, every devcie has the same ID for one user.

    When setting the whole pst File to the roamign folder - it works. But than logging in/out takes a lot more time as the wohle pst must be synchronized.

    For the Mail-and-Calendar app there isn`t even an option to change the folder.

    And the biggest problem for me:
    When the same user logs in on two machines at the same time, the whole sync via z-push fails as both machines sync with same ID at same time. Here I had to re-add the whole account again to make it work again.

    Only solution i found so far:
    Use GPO to set the Device ID to an unique value on log-in.
    Problem here: Haven’t found a generic way to do so. So I had to add a rule for every machine.

    I think, it doesn’t make sense to store a device ID in the user part of the registry. This should be unique to a machine. But as Microsoft did it that way, they seem not to be interested in using ActiveSync in combination with roaming profiles at all.

    Best wishes
    Vogi



  • Hi Vogi,

    thanks for linking your discussion. I think I’ve understand that the problem is the device-ID, that Outlook uses and that will only works correctly, if you use a MS Exchange. So what, one point more to convince the user to use the DeskApp.

    After reading all pro’s and con’s I think the best way for me is to disable the roaming profile on the second pc. It is a laptop that will only used on meetings. So there are not a lot of changes.

    Thanks
    Ulf


  • Banned

    This post is deleted!

Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.