Special Characters are shown as question marks



  • Hey,

    ive upgraded from zarafa to kopano.

    When im Login to my Webapp i see some Special characters as question marks like here:

    Special Characters

    Is there anyway to fix it, i know in zarafa there was a way?

    Best Regards

    Daniel



  • Ive solved it by myself.

    I changed these two entries under /etc/default/kopano.

    KOPANO_LOCALE=“C″
    KOPANO_USERSCRIPT_LOCALE=“C″`
    

    to

    KOPANO_LOCALE=“de_DE.UTF-8″
    KOPANO_USERSCRIPT_LOCALE=“de_DE.UTF-8″`
    


  • I have the same problem, but could not fix it with with the solution above.
    Does someone have an idea?



  • Hello @wndkk

    run

    locale -a
    

    search your language, i bet you want to use de_DE.utf8 (as written by locale -a)
    change it in the default folder and unter /etc/sysconfig/kopano

    if this wont solve your problem use the localize script from phyton:
    https://stash.kopano.io/projects/KSC/repos/core-tools/browse/localize-folders

    python localize-folders.py --lang de_DE.utf8    # same as in the folders, written as "locale -a" tells you
    

    optional you can check it on one user:

    python localize-folders.py --user <username> --lang de_DE.utf8  
    

    hope this helps

    coffee_is_life



  • Neither option worked. I have de_DE and de_CH installed.



  • After running the script several times, it fixed one user. I had to run it for the other ones seperately until it worked on everyone. Seems kind of random though, don’t know why it won’t work every time.
    Thanks though.


Log in to reply