signature image not sent with mail



  • Hello,

    I have the following problem with the webapp: images in the signature are not sent with the mail and therefore not visible on the recieving end.

    How can I solve this?

    I am testing with kopano 8.2.1.531 and webapp 3.2.0.335-19.1

    Best regards,
    Joris


  • Kopano

    @joris said in signature image not sent with mail:

    How can I solve this?
    I am testing with kopano 8.2.1.531 and webapp 3.2.0.335-19.1

    Could you verify if you ran into https://jira.kopano.io/browse/KW-950



  • Hello,

    I checked it, this is not the problem I’m having.

    I used the ‘setdefaultsignature.py’ script to create personalized signatures with the company logo. In the ‘signature.html’-template I have the relative path to the image, sending the mail makes this an absolute path.

    We are looking to replace outlook with the webapp, I did this the same way in outlook, there the relative path is replaced by CID:… and the image is sent with the mail.



  • Hello,

    Is there a solution to this problem?
    I generated a signature with the included script but the images don’t get sent with the email.

    We want to migrate to Kopano but this is holding us back.


  • Kopano

    Hi Joris,

    In your signature.html you can add a base64 encoded image.

    Example:

    <img src="data:image/png;base64, iVBORw0KGgoAAAANSUhEUgAAAAUA
    AAAFCAYAAACNbyblAAAAHElEQVQI12P4//8/w38GIAXDIBKE0DHxgljNBAAO
        9TXL0Y4OHwAAAABJRU5ErkJggg==" alt="Red dot" />
    


  • Thanks Marty, this works.

    Best regards,
    Joris


Log in to reply