Big Calendar not syncronized in Outlook 2016


  • Translator

    Hello,

    I am trying to syncronise an account on Outlook 2016. It works absolutely fine on any device, being iphone, android etc. Kopano webapp shows correctly all the entries.
    This is a personal calendar, not a public one

    However when adding it to Outlook 2016 on the same internal network (i.e. very fast network) the following happens:

    • email after a while appears correctly and functions correctly.
    • The calendar does not appear or if I try to re-add the account several times, occasionally a few would come up then stop and not update anymore.

    I have tried everything including:

    • adding and removing the Outlook activesync account several times.
    • going into the MDM plugin and removing or forcing resync the Outlook profile
    • Selecting less days to be offline in Outlook
    • I tried both on Windows 10 and Windows 7 and the results are the same.
    • I left Outlook running an entire night and still does not update.
    • Clicking send/receive in Outlook many many times, still nothing.

    I am running z-push (and the kopano server) on Debian 8.0 with the following versions:
    Z-push 2.3.4+0

    Kopano-core 8.3.0~500-88.1

    Any help or where you think I should be going from here very much appreciated.


  • Kopano

    Hi,

    is the calendar folder not there at all? Or is it there but stays empty?
    I guess you do see other folder types? Contacts and Tasks?

    Are there other calendars that you see (you could temporarily just create another calendar via webapp).

    Is this something specific to your mailbox? Have you tried another one?

    Cheers,
    Sebastian


  • Translator

    Hi,

    It’s the only account in Outlook. I left it running all night and then the calendar syncronised itself but added double entries in the entire calendar… I.e. double meetings… These ended up in webapp too.

    I have only tried with one account.


  • Translator

    Correction. Nothing yet in Outlook just double entries in Webapp…


  • Translator

    I tried with another account and it works.

    The calendar appears.

    The difference with this account is that it apperas to be containing everything in Inbox and perhaps 10,000 messages so perhaps the calendar is never syncronized.


  • Kopano

    Trying to understand what you mean.
    So, the calendar folder is visible in Outlook, but it stays empty, correct?

    You can execute z-push-admin on your server to see the progress of the account synchronization, use

    z-push-admin -a list -u mcostan
    

    There you should get all your profiles from Outlook and other clients made with your username. As you created several Outlook profiles already, you need to find the current one (probably with the latest “Last Sync” data).

    For better readability you could remove the old profiles (from the Outlook profiles you already deleted on your Desktop) using

    z-push-admin -a remove -u mcostan -d <deviceid>
    

    My guess right now would be that Outlook is still synchronizing. The Inbox is prioritized by Outlook and synchronized first, still, 10.000 emails should not take that long (depends of course on your server & connection speed as well).

    You could also see the interaction with Outlook using z-push-top. If you have several users on your server, you could filter the z-push-top output e.g. with “f:mcostan” or with “f:<your-outlook-device-id>”.
    You see peeks of Outlook requesting data on the server which are then processed by Outlook. You can see the progress of that in the Outlook status bar (“Downloading from server” -> “Updating Inbox” -> “Requesting data from server”). During the update statement you see the amount of elements increase (on the lower left side of status bar) in the folder.

    There have been issues that Outlook hangs updating it’s local data store. In this case the “Updating Inbox” (or any other folder) gets stuck. Perhaps this is the case here as well (see https://jira.z-hub.io/browse/ZP-1158).
    If so, you could try to update to 2.3.5 beta1 as this issue is fixed there.

    Cheers,
    Sebastian


  • Translator

    @Sebastian

    Hi Sebastian,

    What happens is that Outlook appears to be downloading the messages, then it hangs, and when I restart it, I can see a new entry in the z-push connections for my username.

    I am familiar with z-push admin but I have the MDM plugin in webapp and I can see it there too.

    Therefore as time progresses I get more entries in the MDM list (I only have one outlook running) and in the z-push list but Outlook struggles to syncronize.

    I’ll try the beta version of z-push.

    Thanks for your help.


  • Kopano

    Ok, it’s expected to see a new connection if you restart. And yeah, you can also see your profiles in MDM via webapp.

    What do you mean with “I get more entries in the MDM list” ? You mean more profiles? There shouldn’t be more profiles unless you create a new profile in Outlook.

    z-push-admin still shows you more data than the current version of MDM. There is the “messages that need attention” list that could indicate what issue outlook has.

    The beta is probably the right next step IMHO.


  • Translator

    @Sebastian

    In MDM (or z-push) I see say one line for Android, one line for Iphone, one line for Tasks & Notes (an activesync app for Android).

    But I should only see one line for the only Outlook program I have.

    Instead I end up progressively at least today with 3 lines already, i.e. 3 entries in the MDM list.

    All called WindowsOutlook.

    I have now installed the latest version of z-push, cleared up the entries in MDM and restarted Outlook and I will check what’s happening.

    Thanks a lot for your help and I am sorry for taking your time.


  • Kopano

    Yeah, that is what I meant that you will several profiles for each new profile you’ve created in Outlook. The clients don’t tell the server if a profile is removed, so these stay on the server.
    With the latest mdm you can see the last sync time and then remove the other two.


  • Translator

    @Sebastian

    After the version update it has now syncronized. The only change was to set Activesync in Outlook to keep only 1 month of emails.

    I presume perhaps that forces activesync to only syncronize one month of emails? In which case it may be faster, not sure.

    Anyway it appears to be fine now. I am not exactly sure what the issue was, but perhaps it was the same JIRA that was fixed in 2.5.

    Much appreciated.


  • Kopano

    Yeah, quite possible that ZP-1158 influenced in this.
    The bug fixed in ZP-1158 normally only happens if you have emails that are not 100% MAPI conform, e.g. they were imported from somewhere else.
    They cause OL to stall because of one flag OL is not able to handle.

    Either of one could have fixed it. The shorter sync interval could mean that the(se) faulty email(s) were never sent to OL -> no issue, or the fix of ZP-1158 fixed them so that OL can process them correctly.

    Anyway, good that it’s working now.

    Cheers,
    Sebastian


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.