Error with ipcsharedmemoryprovider.php

Hello forum –
I am on z–push 3.8 and I get this error in the z-push-error.log regarding ipsharedmemory

21/09/2017 03:18:24 [ 3333] [WARN] [usernamehere] /usr/share/z-push/backend/ipcsharedmemory/ipcsharedmemoryprovider.php:60 sem_get(): failed for key 0x14: Permission denied (2)
21/09/2017 03:18:24 [ 3333] [ERROR] [usernamehere] IpcSharedMemoryProvider->initSharedMem(): could not aquire semaphore

I have installed z-push on Centos 7 from repo

yum install z-push-core z-push-ipc-sharedmemory

I left the line “define(‘IPC_PROVIDER’, ‘’);” into “./z-push/config.php” unchanged … and I also see the folder “./z-push/backend/ipcsharedmemory” that was created by the installer

File permissions I did not touch anything

drwxr-xr-x. 2 root root  41 Sep 19 16:39 ipcsharedmemory
-rw-r--r--. 1 root root 7344 Sep 14 00:41 ipcsharedmemoryprovider.php

Where do you think is the problem … if it is a problem ? Many thanks

@milauria said in Error with ipcsharedmemoryprovider.php:

I have installed z-push on Centos 7 from repo

Just wondering: from which repo did you install? afaik our repo does not provide a package called ´z-push-core´

Sorry my mistake, I installed “z-push-common” and “z-push-ipc-sharedmemory” modules

I followed the instructions here [https://wiki.z-hub.io/display/ZP/Installation](link url)

and it gave me the “baseurl=http://repo.z-hub.io/z-push:/final/RHEL_7” (for my Centos 7)

This sounds very weird. Could you use ipcs to check the entries and semaphores? Did you change permissions on z-push code during the installation?
Try to remove the semaphores (& entries) and retry. If you have difficulties with that, a reboot could also do that for you.

Cheers,
Sebastian

Hello I am using nginx instead of apache and I have changed ownership of /usr/share/z-push and /etc/z-push and /var/log/z-push to nginx:nginx. I also added nginx to the apache group to be sure of no conflicts.
Could this be the problem? I preferred to replace httpd with nginx as I though it was faster/lighter.
PS – Would be good if the z-push installer script had an option to install with nginx …

See below my ipcs output.

------ Message Queues --------
key msqid owner perms used-bytes messages

------ Shared Memory Segments --------
key shmid owner perms bytes nattch status
0x0000001e 0 nginx 666 2097152 3
0x00000543 32769 nginx 666 1024000 3
0x0000000c 65538 nginx 666 512000 3
0x0000143f 98307 nginx 666 64 0

------ Semaphore Arrays --------
key semid owner perms nsems
0x00000014 65536 nginx 666 3
0x00000539 98305 nginx 666 3
0x00000002 131074 nginx 666 3
0x00001435 163843 nginx 666 3
0x002fa327 196612 root 600 2

@milauria I think you missed z-push’s tmp directory in which the state files, tmp uploads and misc tmp files are stored… chown that to nginx:nginx and chmod to Access: (0750/drwxr-x—) too.

@wiz Which is this directory ?
Under /tmp I don’t have any subdirectory

these are the directory I could find:

[root@proxy tmp]# find / -name z-push
/etc/z-push
/var/lib/yum/repos/x86_64/7/z-push
/var/lib/z-push
/var/log/z-push
/var/cache/yum/x86_64/7/z-push
/usr/share/z-push

and these are all owned by nginx:nginx
Thanks

@milauria hmmm… I’m on centos 7 and am using z-push with nginx too but with selinux disabled and I do not have the issue you are reporting so it’s definitely not z-push.

Do you have selinux enabled?

I checked again today the log file and I didn’t see the ipcsharedmemory error.

I rebooted a couple of times for other reasons and this might have taken the error away.

Let’s park this for the moment
Thanks