[SOLVED] Archive Folders not showning up


I needed to start installing kopano archiver since too much folders are a problem with android device and z-push (if the export takes more thank 30 seconds) - never the less a big folderlist is not that easy to handle ;-)

In Outlook (yes - still using the Zarafa MAPI Client) Archive Folders are shown. For reference I tested with webaccess and they’re shown - but not in WebApp .

Anyone having a hint for me on how to get archives shown in WebApp?


To all that maybe ever run in the same problem. The issue is certificate related. Or better it was… and it solved now.

Let me explain how I solved it myself:

I’m using openldap in my setup. To get archiver running you have to have for each kopano server in use an entry in openldap. When I created these entries I did a mistake because of my understanding of the field names. The is a field called ipHostNumber that needs to have a value. I placed the IP Adress of the servers in there. Actually it would be better to put the server name in there as used in the certificate…

If you run kopano-archiver in debug mode you will see that there is a redirect for the server in the output:
Check server: “mail” ssl=“https://mail.my.domain:237/” flag=00000003

This is how it reads now. Before changing the field in LDAP the IP address was in there stating ssl=“” and well - the IP address was not part of the certificate (not as CN, not as SubjectAltName). It seems furthermore to work for old Zarafa MAPI Client but not for Kopano PHP Mapi used by Kopano WebApp. Unfortunately the message from the logfiles that you get from Kopano WebApp is not that clear since it is more a generic one from that I didn’t get the right clue (“Cannot connect to Kopano Core”).

Another option could be to set another field in ldap_server_address_attribute. I just changed the ipHostNumber to the server fqdn used in the certificates. For sure if you would add the IP Address to SubjectAltNames it should work, too.

I hope this helps someone else if he runs into this problem…


Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.