After Migration: Empty Webapp-Page after login

I try to make the workflow of the migration. I have a clone from our live system in Hyper-V. The Migrationscript is working successfull and kopano is starting successfull (logfile message)

But when I try to connect via WebApp then the login come up and i can put in my credentials. But after i press login a empty page will shown.

kopano-admin -l show me all the migrated users

Here my Infrastructure: AD (Windows 2012 R2) - Zarafa 7.2 => Kopano 8.3 (on Ubuntu 14.04)

Hi @mykey0815 ,

a look into your webserver logfiles should reveal any fatal errors.

No errors in error.log of apache2 - and the access.log show the correct communication between userinput and webserver

Did you have some idea again?

hi @MyKey0815 ,
have you checked the kopano logs under /var/log/kopano?
To help you we need an error message (-:
best regards

I know that you need a error- message - but all the kopano logs are shown that the server/service is startet fine

the error-log of apache is empty to - but so i cant give you a message :-(

Where can I find some hint?

Hi MyKey0815,

Are there any errors in the browser console (ctrl + shift + i)

Yesterday I made a successful migration from zarafa to kopano on my testserver :-)
Can you send us some screenshots?
I had to check my apache Logs and kopano logs serveral times.
Have you eleminated every zarafa webapp-config in your apache config folder?

I have read in the documentation that i need some dependencies (kc-8-dependencies) for the kopano enviroment. So i install w3m and python-mysql. The recommended “libboost-filesystem1.54.1, libboost-system1.54.1” cannot install on Ubuntu 14.04.5. Installed is libboost-filesystem1.54.0 and libboost-system1.54.0

sudo apt-get install libboost-filesystem1.54.1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket libboost-filesystem1.54.1 kann nicht gefunden werden.
E: Mittels regulärem Ausdruck »libboost-filesystem1.54.1« konnte kein Paket gefunden werden.

The Installation of libicu48 is not possible.

Package libicu48 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libicu48' has no installation candidate

Should this the reason, that the empty webpage on webacces is shown and no entry in any logfile is written?

Hi @mykey0815 ,

some these dependencies have in fact been retired with the 8.3 update of Kopano Core (if they would still be required you package manager would also have complained that they are needed to update/install the related Kopano packages). For libicu the wrong version number was given in the manual.

I have updated the linked page to reflect this.

So - I have still the problem with the empty WebAccess Webpage. Now I will describe, what I done:

sudo apt-get install git
sudo apt-get install w3m python-mysqldb libicu52
git config --global http.sslverify false
git clone https://stash.kopano.io/scm/ksc/migrate.git
cd migrate
sudo chmod +x zcp2kc.sh
sudo ./zcp2kc.sh -r 

The Migration runs successfull (?). Then I do following:

mv /etc/apache2/sites-enabled/zarafa-webapp.conf /etc/apache2/sites-available/
service apache2 restart

The schema on the Windows 2012R2 AD is only the old Zarafa Schema. AD Extension is not installed now.
These are the steps, that I read in tej documentation. Is that wrong? Some I forget?

@merlin2104 What are your steps to migrate? Do you do a Inplace-Migration and which HowTo your are follow?

This post is deleted!

Hi,
I basically used this.

https://documentation.kopano.io/kopano_migration_manual/zcp_migration.html
But currently I am writing my own manual .

I also had an access denied error on my webapp. I used “rm /etc/mapi/zarafa.inf” and the error was gone.
My system is based on debian 8.
dpkg -l | egrep ‘(mapi|gsoap|libical|vmime|zarafa)’ | awk ‘{ print $2 }’ | xargs apt-get remove
worked for me - ensure all zarafa packets are gone
dpkg -l |grep zarafa
and
dpkg --list | grep “^rc” | cut -d " " -f 3 | xargs dpkg --purge

Good luck

Hi @MyKey0815

@mykey0815 said in After Migration: Empty Webapp-Page after login:

I have still the problem with the empty WebAccess Webpage.

If you have a subscription I would recommend contacting our support, so that someone could have a direct look at your system.

@MyKey0815
one last suggest - have you checked your mods_enabled in apache?

apt-get install apache2-mpm-prefork libapache2-mod-php5
are required - are they also enabled?

@merlin2104 I have check the mods - but all you mentioned are activated. Now I will try a manuel Inplace-Migration. Have you your working migration steps ready documented? Can you send me you description or is it confidential ;-) ?

Hi @MyKey0815 ,
did the manuel Inplace-Migration succeed ?

@merlin2104 Yes - I have do the manual way of the inplace migration and that works now fine