Search index not requested when using Z-Push

Hi,

when I start a search with the old Zarafa client in Outlook, the search.log gives me the following output and the search in Outlook completes within seconds:

2017-08-02 11:30:10,589 - query - INFO - Command: SCOPE F49B64EF9A274B75B8990BA8B9B6DFCE 5A95DC8F687B46CC9F2F56E264206582 5359537
2017-08-02 11:30:10,589 - query - INFO - Response: OK:
2017-08-02 11:30:10,589 - query - INFO - Command: FIND 55 66 101 3098 3103 3586 3587 3588 4096 32776 33348 34055 34112 34115 34116 35365 35366 35374 35433:test
2017-08-02 11:30:10,590 - query - INFO - Response: OK:
2017-08-02 11:30:10,590 - query - INFO - Command: SUGGEST
2017-08-02 11:30:10,930 - query - INFO - Response: OK: tests
2017-08-02 11:30:10,930 - query - INFO - Command: QUERY
2017-08-02 11:30:10,931 - query - INFO - performing query: (folderid:5359537) AND ((mapi55:test*) OR (mapi66:test*) OR (mapi101:test*) OR (mapi3098:test*) OR (mapi3103:test*) OR (mapi3586:test*) OR (mapi3587:test*) OR (mapi3588:test*) OR (mapi4096:test*) OR (mapi32776:test*) OR (mapi33348:test*) OR (mapi34055:test*) OR (mapi34112:test*) OR (mapi34115:test*) OR (mapi34116:test*) OR (mapi35365:test*) OR (mapi35366:test*) OR (mapi35374:test*) OR (mapi35433:test*))
2017-08-02 11:30:11,258 - query - INFO - Response: OK: 5498150 5498089 [more results...]
2017-08-02 11:30:11,258 - query - INFO - found 1466 results in 0.33 seconds

But if I start a search in Outlook with Z-Push (and the newest OL extension 1.4.209) in the search.log nothing appears and the search takes much more time to complete. The Kopano OL Extension.log also nothing appears regarding the search.

Any hints?

Hi @metagmbh ,

when searching in an ActiveSync profile Outlook always only uses the local search index.

Ok, so a behavior of Outlook which can not be changed…?

Are there any tips how to influence the Outlook search? It seems to work “flaky”, at least since the last updates. I read things about recreating the search index and repairing PST files, however here we have OST files which should not be repaired according to several sources. Instead the mailbox should be synced again - which is not very helpful with large mailboxes.

@isol said in Search index not requested when using Z-Push:

It seems to work “flaky”, at least since the last updates.

Which updates are you referring to? KOE?

Nooo … Outlook 2016 / Windows … many people complain out there, obviously this is not limited to ActiveSync accounts.
I just thought we might as well share experiences and tips here as many people will want to have a working search with their shiny new KOE/Outlook installation. But strictly it is not a Kopano topic at all. Current Outlook seems to have several problems that older versions did not have…

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.