calendar doesn`t show up

Hi,
we (12 people) are using kopano 8.1.1 with ucs4.1 - latest patch level.

My calendar is broken in WebApp and DeskApp. I don`t see any entries anymore (beside in list-view). I´m the only one with this problem. My calendar ist shared - everyone can access it (besides me :-/ )

Changing from day view to week oder month view doesn`t change the display. It always renders day-view without any entries.

I tried

kopano-fsck --user <me>

without any effect.

What can I do, how can it be fixed?

Thanks!
/thorsten

ok, so I found Settings → General → Reset WebApp settings.

Calendar is showing, but all my settings are gone :cry:

Ok, I´m back to bussiness - that´s important.

-close-

@ThorstenS yes, that indeed sounded like an issue with the stored settings. Too bad you have already reset them. If it happens again you can export your webapp settings with kopano-backup and send that in to have it examined.

Hi Felix,

of course kopano-backup is running every night with bareos ;-)
Which file do you want to examine ?

Grüße
/thorsten

The WebApp settings are part of the file called “store”. Probably better to send this in via a support case or to feedback@kopano.io.

Hi ThorstenS,

I’ve moved the topic to the “WebApp” space.

When an invalid setting is set in your calendar settings the rendering of canvas will fail. Since the list view is no canvas the issue does not occur there.
If you happen to stumble upon this issue again try to execute this in the developer console:

container.getContextByName('calendar').model.groupings = undefined

We recently fixed an issue with calendar groupings (this will be part of the 3.3.0 beta1 release)
https://jira.kopano.io/browse/KW-978

thanks marty - I bookmarked this post in my ticket system.
Next time it occurs, I know how to deal with it. :thumbsup:

My way to fix this problem:

  1. Download the tools backup-settings.py and restore-settings.py from:
    https://github.com/zarafagroupware/zarafa-tools/tree/master/webapp

  2. Read out the settings of the user

    python backup-settings.py <USER>

  3. Edit the json File und delete following lines:
    “active_group”: “group-<???>”,
    “groupings”: [],

  4. Restore the settings

python restore-settings.py <USER>

This time I used webapp_settings.py from here:
https://kb.kopano.io/display/WIKI/Backup+and+restore+WebApp+settings

  • webapp_settings.py --user $USER --backup
  • vim $USER.json
    • delete active_group
    • delete groupings
  • webapp_settings.py --user $USER --restore

calendar shows up again.
mission accomplished :first_place:

Hi Thorsten,

If you experience such issues in the latest WebApp, I want to have a look at these settings.
You can send the settings to feedback at kopano dot com.

Thanks :)

It seems we have a similar problem. I just saw this when trying to track a problem with invitations sent from Outlook - I could not see any calendar. Sometimes I get it to work in list view, but the “real” calendars show nothing or “loading”. Is that the same error? How can we diagnose?

I just saw we still have 3.2.0, I will update to 3.3 and report if the problem goes away.