Webapp don't display user store in Multi-tenancy



  • Hello Guys, i need your help …

    it’s a new server install.
    I try to configure Webapp with multi-tenancy mode, but when i a user connect in Webapp with login form "user@domain.org" it work fine, but in the Webapp interface i see in left panel "user@domain.org", but i see nothing for sub-folder ‘Inbox’, ‘Drafts’, ‘Outbox’, ‘Deleted Items’, …
    When i click on user store in left panel, Webapp display a box with this message “Not enough permissions to open this store, do you want to remove it from the hierarchy ?”
    Or when i try to send a e-mail i have this error “Unknown MAPI Error: MAPI_E_STORE_FULL”.

    When i display information for this user by kopano-admin --detail :

    kopano-admin --details franckxxxxxx@DOMAIN.FR
    Username:		franckxxxxx@DOMAIN.FR
    Fullname:		Franck xxxxx
    Emailaddress:		franckxxxxxx@domain.fr
    Active:			yes
    Administrator:		no
    Address book:		Visible
    Auto-accept meeting req:no
    Out Of Office:          disabled
    Last logon:		17/07/2017 12:09:10
    Last logoff:		17/07/2017 12:09:10
    Mapped properties:
    	0x8C6D0102			48 bytes	
    	PR_BUSINESS_TELEPHONE_NUMBER	0000	
    	PR_SURNAME			XXXXXXXXX	
    	PR_EC_ENABLED_FEATURES		imap; mobile; outlook	
    	PR_EC_DISABLED_FEATURES		pop3	
    Current user store quota settings:
     Quota overrides:	yes
     Warning level:		0.00 MB
     Soft level:		0.00 MB
     Hard level:		0.00 MB
    Current store size:	0.00 MB
    Groups (1):
    	Everyone
    

    And i can login in store with MAPI with telner command lines :

    root@mailz2:/etc/kopano/webapp# telnet 127.0.0.1 143
    Trying 127.0.0.1...
    Connected to 127.0.0.1.
    Escape character is '^]'.
    * OK [CAPABILITY IMAP4rev1 LITERAL+ AUTH=PLAIN] IMAP gateway ready
    . LOGIN franckxxxxx@domain.fr PASSWD
    . OK [CAPABILITY IMAP4rev1 LITERAL+ CHILDREN XAOL-OPTION NAMESPACE QUOTA IDLE] LOGIN completed
    . LIST "" "*"
    * LIST (\Noselect \HasChildren) "/" "Public folders"
    * LIST (\HasNoChildren) "/" "&AMk-l&AOk-ments supprim&AOk-s"
    * LIST (\HasNoChildren) "/" "&AMk-l&AOk-ments envoy&AOk-s"
    * LIST (\HasNoChildren) "/" "Courrier ind&AOk-sirable"
    * LIST (\HasNoChildren) "/" "Brouillons"
    * LIST (\HasNoChildren) "/" "INBOX"
    * LIST (\HasNoChildren) "/" "Bo&AO4-te d'envoi"
    . OK LIST completed
    

    My kopano-server (server.cfg) is configured with LDAP for multi-tenancy. And when i list my company, all is good.

    Software version :
    OS : Linux Ubuntu 16.04
    Kopano core : 8.4.0
    Webapp : 3.4.0.758_514

    Do you any suggestions ?

    Thanks.

    Franck


  • Kopano

    Hi @fgoirand ,

    sounds a bit like the store wasn’t properly created. can you unhook the store from the user and then create a new store for your user?



  • Hi @fbartels

    Your a the Winner, thank you. You save my day.
    For all people my commands for solve :

    # kopano-admin --unhook-store franckxxxxxx@domain.fr
    Store unhooked. Store guid is B1D053D778EE42A28FEE29867735C72B
    # kopano-admin --remove-store B1D053D778EE42A28FEE29867735C72B
    # kopano-admin --create-store franckxxxxxx@domain.fr
    

    I don’t understand why the first time store don’t working…

    Thanks

    Franck