e-mail is causing error

Hi Forum,

e-mails from a specific partner causing errors every time:

Error:

 Broken object:  'SyncMail' ignored on '2017-06-14 13:56'
        Information:    Subject: 'Transport order: e-LC file ref 031031851' - From: '"Partner User" <Partner-User@his-domain.biz>'
        Reason:         Message was causing loop (2)
        Item/Parent id: Uef531:f0bc882a8e0f410aa9765bd325976fe7ddc0a4000000/Uef531

Header from mail:

Return-Path: <Partner-User@his-domain.biz>
Received: from mx01.our.domain (127.0.0.1:34272)
	by mailsrv.our.domain (kopano-dagent) with LMTP
	for <vitalis.name@our.domain>; Wed, 14 Jun 2017 13:40:17 +0200 (CEST)
X-Original-To: michael.name@our.domain
X-Original-To: simon.name@our.domain
X-Original-To: vitalis.name@our.domain
Received: from manageserver.our.domain (manageserver.our.domain [172.16.x.xxx])
	by mx01.our.domain (Postfix) with ESMTP id 0678D24780;
	Wed, 14 Jun 2017 13:40:13 +0200 (CEST)
Received: from mia0vm-cass02.colo.sonicwall.com ([208.17.117.5])
	by manageserver.our.domain (SonicWALL 7.6.1.4221)
	with ESMTP id 201706141139430047788; Wed, 14 Jun 2017 13:39:47 +0200
Authentication-Results: mia0vm-cass02.colo.sonicwall.com;none
Received: from smtp74-in.cegeka.be ([212.113.83.80])
	by mia0vm-cass02.colo.sonicwall.com ([10.110.75.122]) (SonicWALL 9.0.1.1221 )
	with ESMTP id i201706141140120210119-2; Wed, 14 Jun 2017 07:40:15 -0400
X-IronPort-AV: E=Sophos;i="5.39,340,1493676000"; 
   d="pdf'?scan'208";a="49492092"
Received: from unknown (HELO ECCBEHAPEXH01.ewalsgroup.local) ([212.113.78.79])
  by smtp74-out.cegeka.be with ESMTP/TLS/AES256-SHA; 14 Jun 2017 13:40:12 +0200
Received: from ECCBEHAPCOR21 (10.13.250.66) by eccbehapexh01.ewalsgroup.local
 (10.13.250.140) with Microsoft SMTP Server id 14.3.235.1; Wed, 14 Jun 2017
 13:40:12 +0200
Message-ID: <196221297.1497440412017.JavaMail.sys_cordys@ECCBEHAPCOR21>
Date: Wed, 14 Jun 2017 13:40:12 +0200
From: Partner Name <partner-user@his-domain.biz>
Reply-To: <partner-user@his-domain.biz>
To: "vitalis.name@our.domain" <vitalis.rupp@our.domain>,
	"simon.name@our.domain" <simon.name@our.domain>,
	"michael.name@our.domain" <michael.name@our.domain>
Subject: Transport order: e-LC file ref 031031846
MIME-Version: 1.0
Content-Type: multipart/mixed;
	boundary="----=_Part_2436_2037282627.1497440412015"
X-Mlf-SPF: SPF Disabled (result=disabled;)
X-Mlf-DKIM: DKIM Disabled (result=disabled;)
X-Mlf-DMARC: DMARC Disabled (result=disabled;)
X-Mlf-Language-Detected: NoLanguageFilter_English
X-Mlf-Connecting-IP: 212.113.83.80
X-Mlf-Country-Code: EU
X-Mlf-Rules: rn;33.10
X-Mlf-SVM: sn;1.000:44:7:0:37
X-Mlf-SVM-Version: 20170518112110; 0
X-Mlf-Tp-MsgRecvd: 2017 06 14 1140
X-Mlf-Tp-Versions: AT1138;I41138;PB1138;SB1138;TT1138;VR1139;WH1138;XB1138;
X-Mlf-Rules-Version: s20170610164631; ds20170309190813;
	di20170519174507; ri20160318003602; fs20170609235843
X-Mlf-Rules-Pos-Features: NGRAM_please_find_10.20;NGRAM_automatic_generate
	d_3.70;NGRAM_order_can_3.39;NGRAM_therefore_does_3.19;NGRAM_carrier_portal_3
	.14;NGRAM_your_carrier_2.94;NGRAM_carrier_please_2.92;SENDER_ines_2.67;
X-Mlf-Rules-Neg-Features: NGRAM_file_ref_-0.92;NGRAM_file_reference_-0.74;
	DOMAIN_SUFFIX_biz_0.00;DOMAIN_SUFFIX_de_0.00;HEADERNGRAM_message-id_date_0.0
	0;HEADERNGRAM_mime-version_content-type_0.00;HEADERNGRAM_to_subject_0.00;RE_
	ACTUAL_TOKEN_0.00;
X-Mlf-Sliderbars: N4,B4,S4,L4,Q4,G4,A4,I4
X-Mlf-CassCloud: sn=C0EAE4CCEE00;vr=3;ls=q;ds=q;lp=q;dp=q;lv=q;dv=q;js=1;do=none;jv=7.6.1.4221;
X-Mlf-Threat-History: nothreat
X-Mlf-Threat-Detailed-History: nothreat;other_hasattach;none;none
X-Mlf-Version: 9.0.1.1221
X-Mlf-License: BS___AP__
X-Mlf-UniqueId-History: i201706141140120210119
X-Mlf-Connecting-IP: 208.17.117.5
X-Mlf-Country-Code: --
X-Mlf-Threat: nothreat
X-Mlf-Threat-Detailed: nothreat;other_hasattach;none;cloud-nj
X-Mlf-License: BS_____
X-Mlf-Version: 7.6.1.4221
X-Mlf-UniqueId: i201706141139430047788
X-Mlf-CassJunkstore: CloudServerUp

It should directly sync to Inbox - via WebApp no Problem, z-push spamms:

14/06/2017 13:56:18 [1918] [ INFO] [our-user] StateNotFoundException: FileStateMachine->GetState(): Could not locate state '/var/lib/z-push/f/6/0ad4dc0aca2a4f7896880791cb924b6f-11601347-93ca-4429-8c9f-fdf01bd2f205-1970' - code: 0 - file: /usr/share/z-push/lib/default/filestatemachine.php:119
14/06/2017 13:56:18 [1918] [WARN] [our-user] Ignored incoming change, global status indicates problem.

Fun-Fact: The item “/var/lib/z-push/f/6/0ad4dc0aca2a4f7896880791cb924b6f-11601347-93ca-4429-8c9f-fdf01bd2f205-1970” does not exist.

After Outlook restart:

14/06/2017 13:56:18 [ 1918] [ INFO] [our-user] cmd='Sync' memory='9.71 MiB/11.50 MiB' time='0.49s' devType='WindowsOutlook' devId='0ad4dc0aca2a4f7896880791cb924b6f' getUser='our-user' from='172.16.xx.xx' idle='0s' version='2.3.6+0' method='POST' httpcode='200'
14/06/2017 13:56:21 [ 1918] [ INFO] [our-user] StateNotFoundException: FileStateMachine->GetState(): Could not locate state '/var/lib/z-push/f/6/0ad4dc0aca2a4f7896880791cb924b6f-11601347-93ca-4429-8c9f-fdf01bd2f205-1970' - code: 0 - file: /usr/share/z-push/lib/default/filestatemachine.php:119
14/06/2017 13:56:22 [ 1918] [WARN] [our-user] Mobile loop detected! Messages sent to the mobile will be restricted to 1 items in order to identify the conflict
14/06/2017 13:56:23 [ 1918] [WARN] [our-user] Mobile loop detected! Messages sent to the mobile will be restricted to 2 items in order to identify the conflict
14/06/2017 13:56:23 [ 1918] [ERROR] [our-user] Ignored broken message (SyncMail). Reason: '2' Folderid: 'Uef531' message id 'Uef531:f0bc882a8e0f410aa9765bd325976fe7ddc0a4000000'

Any ideas?

Coffee_is_life

I can’t imagine that the email itself is the issue. Do you have detailed WBXML logs of this user before/when this email is being synchronized?

sadly not -

via “z-push-admin -a list -u <username>” i can see the messages (first code-box)

is it possible to try a resync of this specific element? - if yes i could deliver the wbxml-log today

Coffee_is_life

You can only resync folders, not specific elements.

But you could:

  1. enable wbxml
  2. move the message to another folder
  3. sync
  4. move it back
  5. sync

Then it should be in the wbxml log.

Cheers, Seb