• Hello, since a couple of weeks we experience problems with autocomplete in outlook which seems to forget addresses, forcing users to pull well-known addresses that they regularly write mail to from the GAB. We are using Outlook 2016 (currently 16.0.13328.20350) and KOE 2.1.20 on Kopano 8.7.16 .
    It seems to be affecting many, but probably not all users.

    Have other people seen this issue? I remember that this once happened 1-2 years ago and then vanished with a KOE change (?).

    Best regards, Jakob Curdes


  • Additional information: two users with the same outlook setup but without KOE installed, do not experience problems with autocomplete in Outlook. So it seems to be KOE-related.


  • Jepp we are experiencing the same since changing from OL 2013 with Zarafa client to 2016 / 2019 with KOE.
    Every now and then the autocomplete list is lost, or some entries of this list get lost. Also sometimes this list gets filled with false random stuff. Contacts from GAB like meyer.mueller@company.com are shown in the autocomplete like meyer.müller@company.com. Thing is, they were never entered like that, nor was a mail send to this false address. Sometimes i’ve seen this with a fresh installation.

    With Zarafa client (not supported I know) and OL 2016/2019 the autocomplete works differently / better. I could never observe that the entries are lost. Better, it looks like the autocomplete list is synced to Kopano server. If a user has some entries in his list and I do a fresh reinstall of Windows and Outlook, the entries will be restored automatically.

    I know from the past that from OL 2013 to 2016 Mircrosoft changed something with the way they are handling the autocomplete list. 2013 and former are using xxx.NK2 files stored within %localappdata% of each user. With 2016 and newer it changed. There arent any .NK2 files anymore.

  • Kopano

    Hi @isol,

    which Z-Push version are you using?

    Could you explain more detailed what you mean by “forget addresses”? The user starts to type a name in to field of someone from GAB and Outlook doesn’t resolve it? Or the dropdown list (autocomplete) with the suggestions doesn’t appear? Do the suggestions appear if the user clicks on “Check names” button in the compose email window?

    @isol said in Autocomplete problems with OL 2016:

    Additional information: two users with the same outlook setup but without KOE installed, do not experience problems with autocomplete in Outlook. So it seems to be KOE-related.

    That is strange because if they use Outlook over ActiveSync and never had KOE installed, the GAB wouldn’t be available for them the way it’s available for the users with KOE.

    Manfred

  • Kopano

    Hi @Pax,

    @Pax said in Autocomplete problems with OL 2016:

    Every now and then the autocomplete list is lost, or some entries of this list get lost. Also sometimes this list gets filled with false random stuff. Contacts from GAB like meyer.mueller@company.com are shown in the autocomplete like meyer.müller@company.com. Thing is, they were never entered like that, nor was a mail send to this false address. Sometimes i’ve seen this with a fresh installation.

    Did you observer this behaviour for the users using Outlook over ActiveSync with KOE? Is there a contact like meyer.müller@company.com in their contacts’ folder or in some public contacts folder?

    With Zarafa client (not supported I know) and OL 2016/2019 the autocomplete works differently / better. I could never observe that the entries are lost. Better, it looks like the autocomplete list is synced to Kopano server. If a user has some entries in his list and I do a fresh reinstall of Windows and Outlook, the entries will be restored automatically.

    Outlook over ActiveSync doesn’t have the same features/possibilities as the zarafa client. KOE solves some of them, but not to the same extent.

    Manfred


  • @Manfred : Entries from the GAB work; we are talking about the dropdown list, sometimes outlook does not find any entries when you start typing and sometimes only some entries are found, but not the relevant one (which has been successfully used yesterday e.g.). I am not sure if “check names” helps.

    I know there are problems with that list on the outlook side, but what haunts me is that the two users (out of about 30 in total) that configured their calendars and contacts, and after that uninstall KOE (which means the additional folders remain but you cannot change them), do not have this problem. For them, autcomplete works flawlessly.

    We were using z-push 2.5.2 there; two days ago I updated it to 2.6.0. We had massive problemls after that with a shared calendar the prevented syncing mailboxes altogether, but that is a different story.
    It is too early now to really tell if the problem is related to the z-push version.

    Best regards, Jakob Curdes

  • Kopano

    Hi @isol,

    do all users with KOE experience this or only some? Were there some Outlook or Office updates?

    Manfred


  • Hi @all,
    we also have very strange behavior with the “Vorgeschlagene Kontakte” and this was even before upgrading to 2.6

    suddenly very old Mailadresses were suggested and newly added were gone.
    (Outlook 2016 (volume) KOE 2.1 (last stable))


  • @Manfred, for us I can say that this problem appeared for all users with KOE installed at least with the office versions 16.0.5071.1000 and 16.0.13328.20408. We think it did not happen before (although some time in the past, we had this problem already and it somehow went away). We had z-push 2.5.2, now we have 2.6.0, it is still too early to tell if the problem persists with 2.6.0. We will ask the users for feedback and get back to here.


  • @Manfred said in Autocomplete problems with OL 2016:

    Hi @Pax,

    @Pax said in Autocomplete problems with OL 2016:

    Every now and then the autocomplete list is lost, or some entries of this list get lost. Also sometimes this list gets filled with false random stuff. Contacts from GAB like meyer.mueller@company.com are shown in the autocomplete like meyer.müller@company.com. Thing is, they were never entered like that, nor was a mail send to this false address. Sometimes i’ve seen this with a fresh installation.

    Did you observer this behaviour for the users using Outlook over ActiveSync with KOE? Is there a contact like meyer.müller@company.com in their contacts’ folder or in some public contacts folder?

    happens only with Outlook over ActiveSync and KOE. For Example: There is a contact in AD like Firstname: Meyer Lastname: Müller Mailadress: meyer.mueller@company.com nothing in Outlook/Kopano Contacts. So with a fresh Outlook installation the Autocomplete should be empty or at least show meyer.mueller@company.com and not with Umlauts

    BUT it is very likely related to segro’s post:

    @segro said in Autocomplete problems with OL 2016:

    Hi @all,
    we also have very strange behavior with the “Vorgeschlagene Kontakte” and this was even before upgrading to 2.6

    suddenly very old Mailadresses were suggested and newly added were gone.
    (Outlook 2016 (volume) KOE 2.1 (last stable))

    Sometimes very old adresses are restored und suggested bei the autocomplete function of Outlook. Even if you delete the Autocomplete list with Outlook internal utilities.
    So for my example. Maybe someone entered meyer.müller@company.com some time ago, deleted it later and somehow this entrie is restored and suggested again.

    Something strange is happening within the Outlook Autocomplete / Suggested Contacts List.