• Well title says is all - is it still supported ? I’d say yes from the documentation but if so I believe there are some broken dependencies

  • Kopano

    Hi @atakacs,

    I guess you mean “Ubuntu”, not “Ubunutu”. We provide Z-Push packages for various distributions, you can check the available at: https://repo.z-hub.io/z-push:/final/.

    @atakacs said in Is Ubunutu 16.04 still supported ?:

    Well title says is all - is it still supported ? I’d say yes from the documentation but if so I believe there are some broken dependencies

    Which dependencies are broken?

    Manfred


  • @Manfred said in Is Ubunutu 16.04 still supported ?:

    https://repo.z-hub.io/z-push:/final/

    Thanks - yes obviously Ubuntu - typo fixed.

    Some progress here but I have an issue with PHP-MAPI

    FatalMisconfigurationException: PHP-MAPI extension is not available - code: 0 - file: /usr/share/z-push/backend/kopano/mapi/mapitags.php:21
    

    Which I understand is packaged in kopano-core, not part of the ubuntu 16.04 repo (only available from bionic (18.04)).

    Maybe something to do with https://forum.kopano.io/topic/3226/kopano-core-10-0-5-5-on-ubuntu-16-04

  • Kopano

    Hi @atakacs,

    did you configure Kopano repository as described at https://documentation.kopano.io/kopanocore_administrator_manual/installing.html# ? Kopano Core is not a part of the official Ubuntu repository. Or did you install Kopano manually?

    As Felix posted in the thread you mentioned, Kopano packages for Ubuntu 16.04 are also still available, just not in the official Ubuntu repositories.

    Manfred


  • This post is deleted!

  • @Manfred

    So, to recap, I am trying to deploy Z-push on an Ubuntu 16.04 (Xenial) sever.

    As per these instructions my first order of business was to add

    deb http://repo.z-hub.io/z-push:/final/Ubuntu_16.04/ /
    

    In my list of repositories

    But this is not enough because in order to get z-push-backend-kopano to work I will also need the php-mapi packages, which is produced by Kopano/Zarafa.

    My understanding those are “kind of” available without a paid subscription. You can get the latest dev (but not the stable that one would presumably want to run) build from https://download.kopano.io/community/

    As such I have to download the archive and set is a local source for apt. I downloaded core-10.0.5.5.1b82983-Ubuntu_16.04-amd64.tar.gz - which I suppose is what I need.

    But then what am I supposed to install, in which order ? Can’t seem to figure it out (or there might be an issue…).

    I would guess I need the php7-mapi package but I get

    The following packages have unmet dependencies:
     php7-mapi : Depends: kopano-client (= 10.0.4.0.b38037084-0+38.1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    

    Whereas kopano-client has the following missing dependencies

    The following packages have unmet dependencies:
     kopano-client : Depends: libgsoap-kopano-2.8.101 but it is not installable
                     Depends: libkcsoap0 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    

    And libgsoap-kopano-2.8.101 is not part of the package.

    So that’s pretty much as far down the rabbit hole I have been.

    Any input most welcome

  • Kopano

    @atakacs FYI since builds were broken in core for 16.04 and two newer lts releases are already available for Ubuntu, we ended up disabling it.


  • thanks - so what concrete advise do you have for me ?

  • Kopano

    @atakacs said in Is Ubuntu 16.04 still supported ?:

    so what concrete advise do you have for me ?

    if you are dead set on 16.04. You could buy a Kopano subscription, which gives you access to our qa’ed releases, which still includes 16.04. (this is what I would recommend for any production deployment anyways)

    If you are set on not buying a subscription you’d have to upgrade to for example 18.04 or 20.04 and continue using the nightly downloads.


  • aha

    so Ubuntu 16.04 is indeed not supported… I can understand it but you should update your documentation. Would have saved me a LOT of time :(

  • Kopano

    There are multiple dimensions to it. Like I said for our customers it is still supported (in regards to core). For Z-Push in general it is supported as well.

    Nothing that is part of the nightly downloads is formally supported and only provided “as is” and without guarantees.


  • @fbartels said in Is Ubuntu 16.04 still supported ?:

    For Z-Push in general it is supported as well.

    Ok you lost me here…

    All I need is Z-Push. Z-Push has a dependency to php7-mapi. How do I get it on 16.04 ?

    Or did you mean “16.04” is supported only for paying customers - which, again, I can perfectly understand… as long as you make it clear.

  • Kopano

    @atakacs said in Is Ubuntu 16.04 still supported ?:

    Z-Push has a dependency to php7-mapi.

    Z-Push itself does not have a dependency on it, only the Kopano backend of Z-Push has it.

    Z-Push is a server implementation of the ActiveSync OTA protocol. For it to be usable you need a data backend for it. This backend can be Kopano, but could be IMAP, CalDAV, Zimbra, … as well.

    As long as you do not install the Kopano Z-Push backend, you will be able to install Z-Push without any packages downloaded from download.kopano.io (nightly or supported).

    Which backend do you want to use?


  • Aha - thanks for clarifying this.

    I’m happy to use any backend that works :)

    I just need ActiveSync OTA for Calendar, Contacts and mail for my otherwise working Zimbra 8.8.12 server.

    Any advice ?

  • Kopano

    Well, you could have saved us all a LOT of time, if you would have said that you wanted to use Z-Push with Zimbra ;-)

    I am not using the Zimbra backend myself, but you can find it at https://sourceforge.net/projects/zimbrabackend/


  • You have a point :)

    In fact, that server was working perfectly with Z-push and Kopano community back-end until we updated Zpush to 2.5.2 (from repo).

    So to be honest I did no really think about switching backend but insisted to continue to use the current solution…

    That being said I suppose this will happen to anyone using Kopano community on 16.04. I guess google will bring them to this thread but maybe you should put some notice in a FAQ / support page

  • Kopano

    Now, you got me confused. Are you using Zimbra or Kopano for your groupware?

    I also thought you were talking about a new installation. Which version did you use before? What stopped working when you upgraded?


  • Not completely clear to be honest (I have not deployed the server, just “inherited” it).

    All I did was to apply the latest update to Z-Push (they were using 2.4.xxx) and it stopped working.

    Checking the logs I saw there was an issue with "PHP-MAPI extension is not available ". Googling it I found out that it was part of the Kopano core package, hence my quest to have it working under 16.04…


  • Ok seems there is a bit of a mess on this server

    ubuntu@zimbrams:/$ dpkg -l z-push*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    un  z-push         <none>       <none>       (no description available)
    rc  z-push-autodis 2.3.8+0-0    all          Z-Push autodiscover
    rc  z-push-backend 2.3.8+0-0    all          Z-Push caldav backend
    rc  z-push-backend 2.3.7+0      all          Z-Push carddav backend
    rc  z-push-backend 2.3.7+0      all          Z-Push combined backend
    rc  z-push-backend 2.3.7+0      all          Z-Push searchldap backend
    rc  z-push-backend 2.3.7+0      all          Z-Push imap backend
    un  z-push-backend <none>       <none>       (no description available)
    rc  z-push-backend 2.3.7+0      all          Z-Push ldap backend
    ii  z-push-common  2.5.2+0-0    all          open source implementation of the
    rc  z-push-config- 2.3.7+0      all          Z-Push apache configuration
    rc  z-push-config- 2.3.8+0-0    all          Z-Push autodiscover apache config
    ii  z-push-ipc-mem 2.5.2+0-0    all          Z-Push ipc memcached provider
    rc  z-push-state-s 2.3.7+0      all          Z-Push mysql state backend
    

    Not sure what my best course of action is…

  • Kopano

    Hi @atakacs

    just to follow this up a bit.

    @atakacs said in Is Ubuntu 16.04 still supported ?:

    You have a point :)

    In fact, that server was working perfectly with Z-push and Kopano community back-end until we updated Zpush to 2.5.2 (from repo).

    I doubt that very much. Z-Push Kopano backend requires a Kopano server, it won’t work with any other groupware solution.
    I suppose the BACKEND_PROVIDER setting in config.php was ‘BackendZimbra’ which was overwritten when you updated Z-Push.

    @atakacs said in Is Ubuntu 16.04 still supported ?:

    Ok seems there is a bit of a mess on this server

    ubuntu@zimbrams:/$ dpkg -l z-push*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name           Version      Architecture Description
    +++-==============-============-============-=================================
    un  z-push         <none>       <none>       (no description available)
    rc  z-push-autodis 2.3.8+0-0    all          Z-Push autodiscover
    rc  z-push-backend 2.3.8+0-0    all          Z-Push caldav backend
    rc  z-push-backend 2.3.7+0      all          Z-Push carddav backend
    rc  z-push-backend 2.3.7+0      all          Z-Push combined backend
    rc  z-push-backend 2.3.7+0      all          Z-Push searchldap backend
    rc  z-push-backend 2.3.7+0      all          Z-Push imap backend
    un  z-push-backend <none>       <none>       (no description available)
    rc  z-push-backend 2.3.7+0      all          Z-Push ldap backend
    ii  z-push-common  2.5.2+0-0    all          open source implementation of the
    rc  z-push-config- 2.3.7+0      all          Z-Push apache configuration
    rc  z-push-config- 2.3.8+0-0    all          Z-Push autodiscover apache config
    ii  z-push-ipc-mem 2.5.2+0-0    all          Z-Push ipc memcached provider
    rc  z-push-state-s 2.3.7+0      all          Z-Push mysql state backend
    

    Not sure what my best course of action is…

    The best is probably to remove all those obsolete Z-Push packages and follow installation instructions for the latest Zimbra backend version.

    Manfred