Unable to install Calendarimporter and Contactimporter Plugins



  • Hi,

    I came across these plugins:

    https://git.sprinternet.at/zarafa_webapp/calendarimporter
    https://git.sprinternet.at/zarafa_webapp/contactimporter

    But I am unable to install them. They seem to be recognized by webapp, but the entries in the Plugins section won’t show up.

    Using the current Kopano Nightlies and the current git of the Plugins.

    The Apache log shows that the plugin files are accessed, and the plugin settings also show up in the “extended settings”. But no UI Elements are added.

    Does anybody have a hint for me?

    Best,

    KMS


  • Kopano

    @h44z do you have an idea here?



  • After some experimenting, my problem changed slightly:

    I now used the plugins from the deploy/plugin folder and copied them to webapp/plugins.

    Contactimporter shows up in the settings, also the menu entries when right-clicking on a contacts folder appear. However, nothing happens if they are clicked.

    As soon as I move Calendarimporter to the plugins folder, I cannot access settings anymore.

    Is this a common issue?

    Best, KMS


  • Kopano

    Hi KMS,

    It would be helpful if you could share the console output after WebApp is loaded
    and when you try to open settings.



  • After some experimenting, im approaching a solution. After manually executing php composer and acquiring the dependencies, the plugins are now visible and accessible.

    Calenderimporter works perfectly!

    However, I have a new issue with Contactimporter:

    After importing a large VCF file (>250 entries), entry properties are duplicated and randomly assigned to arbitrary entries, e.g. companies are randomly assigned to multiple contacts.

    Unfortunately, there is nothing helpful in the logs…

    Best,

    KMS



  • @kms
    Hi, did you triet to pull or sync calendars froma internal source/user on the same Server…if yes, did it worked.

    Best Theo



  • Hi Theo,

    I only used the plugin to import ics files.

    However, my issue with the contactimporter plugin persists.



  • @kms
    Hi,

    I had the same problem with the contactimporter plugin and fixed it.
    I’m sadly on mobile right now, so can’t check the code. But if I remember correctly, in the import function, during a foreach over the new contacts, there was an array that wasn’t reset but always reused.
    If you look over your contacts, you will find that most of the times the duplicated items are only happening if the value was assigned for the previous, but not the current one.
    I can upload the fix later this evening (German time).

    Regards,
    olia



  • It seems I cannot get (easily) access to the linked git archive. So here is the git commit as patch:

    From 5d5d1e06bbd53927a326c0af25faa85221ca6312 Mon Sep 17 00:00:00 2001
    From: OliA <olia@ktah.net>
    Date: Mon, 12 Jun 2017 16:33:21 +0200
    Subject: [PATCH] fixed error: during contact import values from previous
     contacts are added to current one
    
    ---
     php/module.contact.php | 3 ++-
     1 file changed, 2 insertions(+), 1 deletion(-)
    
    diff --git a/php/module.contact.php b/php/module.contact.php
    index f51ee57..2798d62 100644
    --- a/php/module.contact.php
    +++ b/php/module.contact.php
    @@ -216,6 +216,7 @@ class ContactModule extends Module
                             error_log("New contact added: \"" . $propValuesMAPI[$properties["display_name"]] . "\".\n");
                         }
                         $count++;
    +                   $propValuesMAPI = array();
                     }
                 }
     
    @@ -1201,4 +1202,4 @@ class ContactModule extends Module
             $unescaped = str_replace("\\,", ",", $unescaped);
             return $unescaped;
         }
    -}
    \ No newline at end of file
    +}
    -- 
    2.9.3
    


  • Thanks a lot! That did the trick!

    As a reward, I can provide a workaround to obtain more than 10 search results when using android and z-push ;-)

    Best,

    KMS


  • Translator

    question: is there now a repository with the updated version of the code?


  • Kopano

    @kms said in Unable to install Calendarimporter and Contactimporter Plugins:

    I can provide a workaround to obtain more than 10 search results when using android and z-push ;-)

    can you explain a bit more what you patch does? If you are willing we are always open to pull requests, see https://wiki.z-hub.io/display/ZP/Development+guidelines for more information.



  • I got around to install the ContactImporter plugin and make it to show it up in the plugin list where it can be enabled.
    However, no context menu pops up when clicking on any contacts folder.
    Can someone familiar with this plugin please help to debug it further?

    I feel this is a severe limitation of Kopano, for not having a supported way of importing contacts. Perhaps this is the catch… pony up for support to get support

    I am using WebApp: 3.3.0.610-25.1 / Kopano Core: 8.3.1-35 / Z-Push: 2.3.6+0


  • Kopano

    Hi @lleopold19 ,

    there is always the kopano-migration-pst tool. For every system I’ve seen so far there is either a direct way of exporting pst or via third party tools.



  • @lleopold19 AFAIK the ContactImporter Plugin doesn’t add any context menus. You access the plugin via “Import Contacts” (bottom left corner) in the “Contacts” Tab:
    kopano_import_contacts



  • I appologize from kopano and its developers, I sounded as a bad troll, and that was not my intention.

    Thanks Olia for your reply, that button does not show for me. That is my problem and cannot find anything errors in logs. The reason for suspecting a context menu issue is that when the plugin is disabled I can get a standard context menu by right clicking contact folders. With the plugin enabled I do not get it. Still get a menu on other folders, like deleted items, etc.

    My contacts are not available in PST format, and after many years since touching outlook for email, not exactly sure how to get them into PST format.
    Any suggestion and that direction would also be appreciated.



  • If you need to do only a one-time import, maybe try if that script here still works:
    csv2contacts

    Otherwise, did you look in the console log from the Browser, or test it in Firefox/Chrome/Edge? Could be some javascript issue? Maybe some Browser plugin interferes.



  • thanks, how did I not think of this… focused on server only…

    Getting a “TypeError: Zarafa.plugins.contactimporter.ui is undefined” in both Firefox and Chrome


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.