• Hello,

    i tried with different python versions the setdefaultsignature.py but i got several errors.

    raceback (most recent call last):
      File "setdefaultsignature.py", line 2, in <module>
        from MAPI.Util import *
      File "/usr/lib/python2.7/dist-packages/MAPI/__init__.py", line 4, in <module>
        from MAPICore import *
      File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 21, in <module>
        _MAPICore = swig_import_helper()
      File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 20, in swig_import_helper
        return importlib.import_module('_MAPICore')
      File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
        __import__(name)
    ImportError: /usr/lib/x86_64-linux-gnu/libmapi.so.1: version `KC_8.7.3' not found (required by /usr/lib/python2.7/dist-packages/_MAPICore.so)
    
    or
    
     File "setdefaultsignature.py", line 29
        print 'User \'%s\' has no user store (%s)' % (username, e)
    

    Is there an update availiable ?

    Thanks

    Thomas

  • Kopano

    @tboernert said in setdefaultsignature.py not working:

    version `KC_8.7.3’ not found

    Which version are you currently running? I would recommend to upgrade to the latest release available to you.


  • Hi @fbartels ,

    i use

    WebApp:
    3.5.14.2539+111.1
    Kopano Core:
    8.7.12

    Thomas

  • Kopano

    @tboernert the you seem to have some half upgraded packages. Since it’s still looking for the 8.7.3 abi.


  • Hi @fbartels

    ii kopano-backup 8.7.12.0-0+20.1 amd64 Utility to back up and restore Kopano stores
    ii kopano-client 8.7.12.0-0+31.1 amd64 Kopano MAPI provider library
    ii kopano-common 8.7.12.0-0+31.1 amd64 Shared files for Kopano services
    ii kopano-dagent 8.7.12.0-0+31.1 amd64 E-Mail Delivery Agent for Kopano Core
    ii kopano-dagent-pytils 8.7.12.0-0+20.1 amd64 Additional message handlers for kopano-dagent
    ii kopano-gateway 8.7.12.0-0+31.1 amd64 POP3 and IMAP Gateway for Kopano Core
    ii kopano-ical 8.7.12.0-0+31.1 amd64 ICal and CalDAV Gateway for Kopano Core
    ii kopano-lang 8.7.12.0-0+31.1 all Translations for Kopano Core components
    ii kopano-migration-pst 8.7.12.0-0+20.1 amd64 Utility to import PST files
    ii kopano-monitor 8.7.12.0-0+31.1 amd64 Quota Monitor for Kopano Core
    ii kopano-python-utils 8.7.12.0-0+20.1 amd64 Additional Python-based command-line utils for Kopano Core
    ii kopano-search 8.7.12.0-0+20.1 amd64 Indexed search engine for Kopano Core
    ii kopano-server 8.7.12.0-0+31.1 amd64 Server component for Kopano Core
    ii kopano-server-packages 8.7.12.0-0+31.1 all Metapackage to install the entire Kopano Core stack
    ii kopano-spooler 8.7.12.0-0+31.1 amd64 E-mail Spooler for Kopano Core
    ii libkcarchiver0 8.7.12.0-0+31.1 amd64 Library with shared Kopano archiver functionality
    ii libkcarchivercore0 8.7.12.0-0+31.1 amd64 Library with shared Kopano archiver functionality
    ii libkcfreebusy0 8.7.12.0-0+31.1 amd64 Implementation of Free/Busy time scheduling
    ii libkcicalmapi0 8.7.12.0-0+31.1 amd64 iCal interface for MAPI
    ii libkcinetmapi0 8.7.12.0-0+31.1 amd64 Interface between internet e-mail and MAPI
    ii libkcpyplug0 8.7.12.0-0+31.1 amd64 Python interpreter plugin for dagent/spooler
    ii libkcrosie0 8.7.12.0-0+31.1 amd64 Kopano HTML sanitizer interface
    ii libkcserver0 8.7.12.0-0+31.1 amd64 The Kopano Server library
    ii libkcsoap0 8.7.12.0-0+31.1 amd64 SOAP (de)serializer functions for Kopano’s RPCs
    ii libkcutil0 8.7.12.0-0+31.1 amd64 Miscellaneous utility functions for Kopano Core
    ii libmapi1 8.7.12.0-0+31.1 amd64 Kopano’s implementation of the Messaging API
    ii php7-mapi 8.7.12.0-0+31.1 amd64 PHP bindings for MAPI
    ii python3-kopano 8.7.12.0-0+20.1 all High-level Python 3 bindings for Kopano
    ii python3-kopano-search 8.7.12.0-0+20.1 all Kopano search module for Python 3
    ii python3-kopano-utils 8.7.12.0-0+20.1 all Kopano utils modules for Python 3
    ii python3-mapi 8.7.12.0-0+31.1 amd64 Python 3 bindings for MAPI


  • Hi @fbartels

    the error with KC 8.7.3 are appears with python

    with python 3 i got:

    File “setdefaultsignature.py”, line 29
    print ‘User ‘%s’ has no user store (%s)’ % (username, e)


  • Kopano

    @tboernert said in setdefaultsignature.py not working:

    the error with KC 8.7.3 are appears with python

    and the python2 variant is also missing in your above package output.

    In any case I would always recommend to update with apt full-upgrade so that changed and updated dependencies get pulled in as well. Otherwise you will have held back packages which is routinely the cause of mixed up abis.