Login circle spinning forever on Webapp 4.0 beta2 installation on UCS


  • Hello,

    I upgraded my WebApp 3.5.14 to 4.0b2 on our UCS and now the WebApp is spinning the login circle forever without loading/showing the WebApp.
    What can I do to debug this.
    I checked and upgraded the confg-files under /etc/kopano/webapp/* already and I disabled plugins, but I can’t log into it anymore :(

    Any help appreciated, because I don’t like to downgrade an “crash” my user-setting.

    Christian.

    Edit:
    Solved with a workaround … purify.min.js is missing, so I copied a version from an univention-folder to the missing kopano-webapp/client/dompurify/ folder and the login works. Now only an error message after login is left.

    Bildschirmfoto von 2020-04-17 22-36-43.png …?

  • Kopano

    Hi @onex-de

    Thanks for the report.
    I’ve looked into it and should be fixed now (also on the download server).

    Please check it out!


  • Hi marty,

    I can confirm the purify-files in the latest package, but I still get the message “file doesn’t exist anymore”. (see above)

    This file is missing:
    https://[FQDN]/webapp/plugins/htmleditor-minimaltiny/js/htmleditor-minimaltiny.min.js.map

    EDIT (2020-04-21, 09:47 UTC):
    [shift] + [pos1] or [shift] + [end] to select everything from current cursor position to the line start or line end doesn’t work, unfortunately.

  • Kopano

    @onex-de

    Those two messages are unrelated.
    The sourcemap messages is a warning and is harmless. This is also a known issue: https://jira.kopano.io/browse/KW-3065

    The error “File is not available” comes from the Files plugin, so did you upgrade this as well? If so, re-create the account or create the cache again (if on files version 3.x). Right-click top-folder and click reload.


  • I had to recreate my Nextcloud account setting, but now the error message is gone.
    TYVM!