default_signature.py -- KeyError: 'mail'


  • Hi,
    I have got a issue with /usr/share/doc/kopano-webapp/scripts/signatures# ./example_wrapper.sh <username>.

    If I use it with an existing (older) user (which is created month ago), it works. But if I create a new user (Active Directory), I get an error:

    Traceback (most recent call last): File “setdefaultsignature.py”, line 98, in <module> main() File “setdefaultsignature.py”, line 74, in main if not len(webappsettings[‘settings’][‘zarafa’][‘v1’][‘contexts’][‘mail’]):KeyError: ‘mail’

    The (new) user is working correctly with kopano-deskapp/webapp, but I have no chance to use the signature-script.

    Very strange.


  • This post is deleted!

  • So after I recovered my password (thanks for your support in this case) I can now answer my own post:

    It seems like that you have to manually create an empty signature. After doing that, the default_signature.py is working as expected.

    This behavior explains, why it worked with “older” users (with existing signature) and not for new users.

    Before upgrading to a newer built of kopano, this worked out of the box (also with new users).

    kopano-server:
    Installiert: 8.7.9.0-0+16.1

    kopano-webapp:
    Installiert: 3.5.14.2539+111.1


  • Same issue here,
    same solution to fix it.

    so there should be something like a if isset same on line 79 and line 83 etc

    workaround, create a signature for every user and delete it after the import…


  • …same here (after upgrade of UCS)
    Create a dummy signature and it works…


  • Ticket: Link


  • This post is deleted!
  • Kopano

    @f31n @mcdaniels @Gohle @item

    This is fixed in WebApp Admin

    We recommend using this tool over the script in /tools
    The latter wil be removed in the near future as well.