z-push 2.5.1 not passing user name correctly for authentication



  • i just upgraded to the latest synology version of kopan4s that uses z-push 2.5.1 and found a bug/issue on the username authentication within z-push.

    Firstly, all my email usernames in kopano is user@domain.com (this is because i have several domains).
    after upgrading to z-push 2.5.1, it’s only taking the “user” and leaving the “@domain.com” out of the authentication string.

    i’m looking at the z-push.logs and it’s very clear that indicate that and i can reproduce it quite easily with 2 types of users:

    setup a User without @domain and an user with @domain, and it will only authenticate on the user WITHOUT “@domain” appended to it.

    it was working in a previous z-push release. did i miss a step in the setup to accept the full user@domain path?

    thanks.


  • Kopano

    Hi @augner,

    there is a config option in z-push to influence this behaviour. Not sure what is the default for this in Kopano4S.

    https://stash.z-hub.io/projects/ZP/repos/z-push/browse/src/config.php#57



  • hi Fbartels.
    thank you for your insight and solution.

    the upgraded Kopano4S set the value to false in /etc/z-push/z-push.conf.php

    after updating to true, my full email address as user name now can authenticate.

    thank you.



  • Hi,
    Z-Push default azthentication setting in Kopano4S(ynology) is indeed user based. This is / was the default value of z_push 2.3.x package under Synology however this can be changed in z-push configuration and stays persistent at upgrades. I’m happy to expose this configuration piece in the k4s-gui incl. a note for hint in future realeases of kopano4s.
    PS: happy you succeeded with the migration jump from Synology Zarafa 2015 base to Kopano as of 2019/20.
    -TosoBoso


Log in to reply