Multiple copies of same message accumulate in Drafts folder with IMAP.

After a recent upgrade of our system from ZCP to Kopano (which included upgrading the Gateway server) we noticed that our IMAP Clients will auto-save multiple copies of the same message to the Drafts folder. And even after the message is sent, multiple copies remain in the Drafts folder…

The client we are using is Thunderbird (not all are the most recent but many are version 52). There are a number of Knowledgebase articles on the Internet about Thunderbird and GMail with this exact same problem, but none of the workarounds seem to fix the problem.

Is anyone else having this problem? Is there a way to fix it?

Thanks
Bob

We stumbled upon this recently as well, but came to the conclusing that this is simply the nature of imap. Are you sure it wasn`t the same in Zarafa?

See https://jira.kopano.io/browse/KC-652 for more info.

@fbartels I remember seeing it every once in a great while, but it was always a fluke event. But now it is a happening to everyone, regardless of Thunderbird version.
I can’t be 100% sure, but this problem was not reported till after the upgrade and users say it started around that time.

So I have looked at the ticket above and our problem is a little different:

Steps to reproduce:

  • create a new e-mail in Thunderbird
  • fill in some text in the body and fill in a subject
  • save the mail as a draft (or wait for auto-save)
  • open the draft and apply some changes in the body
  • save the draft again (or wait for auto-save)
  • save the draft yet again (or wait for auto-save)
  • check WebApp

What should happen:
Thunderbird (and WebApp) should have one saved draft and this draft should have the most recent content.

What actually happens:
Thunderbird (and WebApp) appear to have three saved drafts. One with the first saved content and the other two with the changes. This behaviour continues to repeat itself every time the draft is manually saved or auto-saved.

@robertwbrandt so your behaviour is mostly the same, only that the email doubles not only in webapp, but also in thunderbird?

did you try the config setting mentioned in the comment?

@fbartels I did, it made no difference.

Bob

@robertwbrandt then please contact support, so that they can have a look at your system.

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.