No access via webapp and z-push after ucs-upgrade



  • Hi Forum,

    since I upgrade ucs to 4.4-3 webapp and z-push got some problems.

    Kopano server can easily be reached via imap and works as desired only with webapp and z-push no chance.
    When I call the page I get an error message: “Secure Connection Failed. The connection to the server was reset while the page was loading.”

    Neither webapp nor z-push doesn’t work like it should.
    I suspect it has something to do with the apache2 configuration. In the apache-error.log I always have the message: …Server name not provided via TLS extension (using default/first virtual host) …

    Later on I removed the webapp configuration files from /etc/kopano. This might not have been a good idea. A reinstallation of koapano-webapp and kopano-z-push didn’t work.

    Now I’m stucked. Is there a way to debug errors from webapp and z-push directly (log-files except apache-error.log and server.log)? Is there a possible way to restore the config files after all?

    Thank you!



  • Hi @uwetz

    This error sounds to me that there is a problem with the certificate apache is using.
    Have you installed a official certificate or are you using the UCS certificates?

    You can find the standard configs under /usr/share/doc/kopano/example-config/.

    Cheers Basti


  • Kopano

    Hi @uwetz,

    @uwetz said in No access via webapp and z-push after ucs-upgrade:

    Is there a possible way to restore the config files after all?

    https://askubuntu.com/a/67028/37075 is explaining how to restore config files from packages.

    edit: and you can the execute the following to reapply config settings stored in the ucr: while read ucrv; do ucr set "$ucrv"="$(ucr get $ucrv)"; done < <(ucr search --brief kopano/webapp | awk -F : '{print $1}')

    @sebschremser said in No access via webapp and z-push after ucs-upgrade:

    You can find the standard configs under /usr/share/doc/kopano/example-config/.

    That is actually only true for configuration files from the server, not webapp or z-push.


Log in to reply