Webapp / Deskapp show E-Mails double or sometimes triple???



  • I can’t find any solution in the forum that helps me - so I hope anybody could give me a little hint?

    All Mails will be fetched and assigned by fetchmail - this works fine so far. But when I use Webapp oder Deskapp mails often shown double or even triple.

    When I take a look at my mobile phone (iPhone) via z-push the messages will be shown in the right way > only 1 mail.

    So what goes wrong - any configs in Webapp or elsewhere?

    Ubuntu 18.04 LTS
    WebApp: 3.5.10.2424+1363.1
    Kopano Core: 8.7.83
    Z-Push: 2.5.0+0-0

    Regards
    Martin


  • Kopano

    @IIIMIIIRIII No scenario springs to mind where WebApp would display messages multiple times when present in the mailbox only once. Do you see anything in the browser console log or web server log that might give a hint?

    It might be that the mails are actually present in the mailbox multiple times, but the mobile device puts them in a ‘thread’ somehow, displaying as if there is only one.



  • I have not checked logs for hints so far. But for understanding here a screenshot from Webapp / Deskapp:

    webapp_deskapp.jpg

    and here same time from ios-device (iphone):

    ios.jpg



  • Once more with more than 3 itmes:

    webapp_deskapp2.jpg

    and again on ios-device:

    ios2.jpg



  • @bhuisman Multiple threads will be shown with two arrows. Sorry, it only shows me one as it is one.


  • Kopano

    @IIIMIIIRIII Do you by any chance have another client connected (e.g. IMAP)?

    Anything odd in the logs (browser + webserver)?



  • @IIIMIIIRIII

    Hi,

    You are feching the mails through fetchmail - i had a similar issue - setting the interval to higher value solved my problem

    maybe you have a slow internet connection - if fetchmail is fetching again and has not fetched the mails complete bevor it takes them multiple times -

    so i would try to set the interval to e.g. 10min or so and try

    rg

    Christian



  • @externa1

    Yes, we using fetchmail - I’ll try it - come back later…


Log in to reply