debian 9 and nginx - mapi extension not found



  • I have problems with webapp on Debian 9 with nginx and php7.3-fpm:

    When I access the webapp I get:

    Not Found: PHP mapi extension not found
    If you have upgraded Kopano Core, please restart Apache
    Kopano WebApp can't start because of incompatible configuration.
    
    Please correct above errors, a good start is by checking your '/etc/php/7.3/fpm/php.ini' file.
    
    You can disable this configuration check by editing the file '/usr/share/kopano-webapp/config.php', but this is not recommended.
    

    However php-mapi is installed:

    php7-mapi is already the newest version (8.7.5.0-0+43.1)
    

    So what am I missing ??



  • OK, it seems that if I enable php7.0 instead of 7.3, everything works fine.

    Is there a version of php-mail for php 7.3 ??


  • Kopano

    Hi @crankshaft,

    we are always only providing a php-mapi version for the default php version of a given distribution (as it needs to be compiled for the abi of a given version). If you want to use a differing php version, then you need to compile php-mapi yourself.



  • @crankshaft have you tried to stop and start of nginx?


Log in to reply