Kopano WebApp Files: Configuration UI not showing up



  • Hi,

    i recently switched from Zarafa to Kopano and wanted now to configure the Files Plugin to connect to my Owncloud server. I have clicked the “Add Account” button and have selected Owncloud but then the Configuration Panel is not showing and additional parameters. I have checked the HTTP communication and it seems that information about configuration fields are send back from the server:
    {“success”:true,“metaData”:{“fields”:[{“name”:“server_address”,“fieldLabel”:“Server address”,“editor”:{“allowBlank”:false}},{“name”:“server_port”,“fieldLabel”:“Server port”,“editor”:{“ref”:"…/…/portField",“allowBlank”:false}},{“name”:“server_ssl”,“fieldLabel”:“Use SSL”,“editor”:{“xtype”:“checkbox”,“listeners”:{“check”:“Zarafa.plugins.files.data.Actions.onCheckSSL”}}},{“name”:“server_path”,“fieldLabel”:“Webdav base path”,“editor”:{“allowBlank”:false}},{“name”:“user”,“fieldLabel”:“Username”,“editor”:{“ref”:"…/…/usernameField"}},{“name”:“password”,“fieldLabel”:“Password”,“editor”:{“ref”:"…/…/passwordField",“inputType”:“password”}},{“name”:“use_zarafa_credentials”,“fieldLabel”:“Use Kopano credentials”,“editor”:{“xtype”:“checkbox”,“listeners”:{“check”:“Zarafa.plugins.files.data.Actions.onCheckCredentials”}}}],“formConfig”:{“labelAlign”:“left”,“columnCount”:1,“labelWidth”:80,“defaults”:{“width”:292}}},“data”:{“server_address”:“demo.owncloud.org”,“server_port”:“80”,“server_path”:"/remote.php/webdav"}}

    I am using Chromium on Ubuntu with Version 55.0.2883.87, but this problem appears also on Windows or in Firefox and IE.

    Here is a screenshot about the problem:
    alt text

    Thank you very much for your help!

    Kind Regards,

    Tobias Lorentz


  • Kopano

    Hi Tobias,

    Did you recently upgrade from Zarafa to Kopano? What version of Files did you use before the upgrade, and what version of Files are you using at the moment? Could you enable error logging in WebApp’s config.php
    (set it to E_ALL) and paste the data you get while accessing your account?

    And if everything else fails, reset your files + webapp settings.



  • Hi,

    yes i recently upgrade from Zarafa to Kopano. I am using Univention and had the latest version of Zarafa available on Univention installed.
    Actually i am having Version 2.0 of the Files plugin and Version 0.1 of the SMB as well as of the Owncloud Backend.
    I changed the Webapp Config:

        // Do not log errors into stdout, since this generates faulty JSON responses.
     ini_set("display_errors", false);
    
        ini_set("log_errors", true);
     //error_reporting(E_ERROR);
     error_reporting(E_ALL);
    

    But within the console of Chrome i do not see any errors. I checked the /var/log/kopano, but there is no log file for the webapp.

    Kind Regards,

    Tobias Lorentz



  • @tobiaslorentz said in Kopano WebApp Files: Configuration UI not showing up:

    Here is a screenshot about the problem:
    alt text

    Hi Tobias,

    I spent a couple of days troubleshooting the exact same issue on Centos 7/nginx/php56 installation and found several bugs with the webapp files plugin and filesbackendOwncloud code.

    @marty FYI

    The first bug is with the BASE_PATH constant in /path/to/kopano-webapp/plugins/files/php/Files/Backend/class.backendstore.php line 8,9,10

    Solution: delete or comment out the whole if BASE_PATH statement. This should get the configuration UI to load properly.


    The second bug deals with the inability to preview files under the Files tab in WebApp - nothing loads. The issue is with the implementation of the new phpfastcache module’s configuration in /path/to/kopano-webapp/plugins/files/php/lib/phpfastcache/phpfastcache.php - specifically, the auto detection of the cache path, ie. ‘path’ including other options such as storage type, permissions which should be defined in the main config.php of the main Files plugin.

    Solution: Set the path manually ‘path’ => “/path/to/cache/folder”,
    Verify other config options match your environment


    The third bug deals with a double ‘foreach’ statement in owncloud’s backend code in /path/to/kopano-webapp/plugins/filesbackendOwncloud/php/class.backend.php - around line 1098

    Solution: Comment out or delete the following:

    foreach ($shares as $id => $options) {
    			$result[$path][$id] = array(
    				"shared" => true,
    				"id" => $options->getId(),
    				"path" => $options->getPath(),
    				"share_type" => $options->getShareType(),
    				"permissions" => $options->getPermissions(),
    				"expiration" => $options->getExpiration(),
    				"token" => $options->getToken(),
    				"url" => $options->getUrl(),
    				"share_with" => $options->getShareWith()
    			);
    		} 
    


  • Hi Wiz,

    thank you for you help. Unfortunately commenting out those 3 lines does not change anything for me.
    Univention is running php in versin 5.4.45. (i executed php -v on the console, might be that the webserver itself is using a different version)

    Kind Regards,

    Tobi



  • I am having the same problem.
    A quick fix that helped here:

    Change …/kopano-webapp/plugins/files/php/Files/Backend/class.backendstore.php from

    namespace Files\Backend;
    
    require_once __DIR__ . "/../Core/Util/class.logger.php";
    require_once __DIR__ . "/../Core/Util/class.stringutil.php";
    

    to

    namespace Files\Backend;
    
    define('BASE_PATH', realpath(dirname(__FILE__)) . '/');
    require_once __DIR__ . "/../Core/Util/class.logger.php";
    require_once __DIR__ . "/../Core/Util/class.stringutil.php";
    

    so that the BASE_PATH is correctly defined.



  • Hi.

    i found out now that this is related to the fact that i am running my server behind a reverse proxy. When i am accessing it via the reverse proxy, it doesn’t work (also when appying the change suggested by Vogi). When i am accessing it directly, then it works.

    When i am adding a SMB connection, then everything works find.
    When adding a owncloud connection, i am getting a red trafic light. Within the http communication i found the following error:

    {“zarafa”:{“error”:{“type”:2,“info”:{“file”:“class.bus.php:293”,“display_message”:“Antwortdaten vom Bus angefragt aber er hat keine Daten.”,“original_message”:“Antwortdaten vom Bus angefragt aber er hat keine Daten.”}}}}

    The owncloud server is running on the same host as the webapp. I tried it with the fqn of the server as well as with local host (both with ssl and without ssl).

    Kind Regards,

    Tobias Lorentz


  • Kopano

    Hi,

    there had been problems with the BASE_PATH some time ago. But that should be solved already.

    Which exact versions of WebApp and Files Plugin are you using?

    For the detection of paths with ningx there is a ticket already: https://jira.kopano.io/browse/KFP-102


  • Kopano

    @tobiaslorentz: As you are using Univention Corporate Server, did you set the “Webdav Base Path” to /owncloud/remote.php/webdav?



  • Hi,

    @bjoernneumann: Thank you very much! My mistake was that i had puttet the “/owncloud” as “localhost/owncloud/” within the server field and not in the base path.

    Kind Regards,

    Tobias Lorentz


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.