Server error when deleting contact oder contact details



  • Hi there,

    I have a strange behaviour of WebApp. One user is complaining that he is getting “HTTP 500 Internal Server Error” when trying to delete certain contacts or details of those contacts (in this case: the date of birth). Apache logs this:

    [Tue May 21 17:48:48.946923 2019] [proxy_fcgi:error] [pid 7585:tid 140248057648896] [client x.x.x.x:56048] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function BaseException::__construct(), 0 passed in /usr/share/kopano-webapp/server/includes/core/class.operations.php on line 2900 and at least 1 expected in /usr/share/kopano-webapp/server/includes/mapi/class.baseexception.php:51\nStack trace:\n#0 /usr/share/kopano-webapp/server/includes/core/class.operations.php(2900): BaseException->__construct()\n#1 /usr/share/kopano-webapp/server/includes/core/class.operations.php(2845): Operations->copyMessages(Resource id #12, '\\x00\\x00\\x00\\x00\\xBD/rJ\\xDA{@:\\xBA\\xAB\\xFB...', Resource id #12, '\\x00\\x00\\x00\\x00\\xBD/rJ\\xDA{@:\\xBA\\xAB\\xFB...', Array, Array, true)\n#2 /usr/share/kopano-webapp/server/includes/modules/class.contactitemmodule.php(503): Operations->deleteMessages(Resource id #12, '\\x00\\x00\\x00\\x00\\xBD/rJ\\xDA{@:\\xBA\\xAB\\xFB...', Array)\n#3 /usr/share/kopano-webapp/server/includes/modules/class.contactitemmodule.php(238): ContactItemModule->deleteSpecialDateAppointment(Resource id #12...\n'
    
    

    It does not happen on every contact. Creating a new one and deleting it afterwards is no problem. Cleared all client caches, tried Firefox as a client browser, Deskapp as well. No help.

    I have no clue what this behaviour may come from. Details of the contacts can be edited and removed on mobile devices via Z-Push without any error messages in Kopano server log or Z-Push log so it must be a WebApp issue.

    WebApp:
    3.5.6.2298+94.1
    Kopano Core:
    8.7.1
    php 7.2.17 (fpm)



  • Hi there,

    I would appreciate any help with this since I am stuck. Did a reinstall of WebApp with no help. Tried to reproduce the error on other accounts which didn’t work. So I normally would think it could be a problem with the database - but no error in server.log and manipulating the contacts is working via Z-Push …

    Thanks in advance for any assistance.


Log in to reply