Unbenannte Anlage XXXX.Dateiendung/ unnamed attachment.file - when using Outlook



  • Hello community,

    i hope there is someone who knows, how to fix this issue:

    I am using Kopano from ubuntu repositories (8.5.5), with the latest z-push version 2.4.5,
    when someone sends me a mail with multiple attachments from Outlook,
    and i receive the mail also in Outlook, all attachments get renamed to “Unbenannte Anlage.X”. (translated "unnamed attachment.X,while X is the correct filetype from source attachment)

    I am not sure, if this is a problem related to german language,
    because there is no one in the internet, writing about this in english.

    I found out that the libvmime package could be related to this,
    but could not find any solution approach, and i am not sure if this is really the problem source.

    So maybe someone out here has an idea how to get this under control, if you need any further information, please let me know.

    Thanks in advance

    Best regards


  • Kopano

    Hi @Chris2,

    could you give this a try with our packages (e.g. from here) and see if you see the same error there?

    PS: if this is an error specific to the downstream packaging it may be worthwhile to report the issue with the maintainer of these packages.


  • Kopano

    Hi Chris2,

    does this happen to all types of attachments (.jpg, .png, .pdf, .xlsx etc)? When one of those “Unbenannte Anlage.X” attachments is sent separately (only one attachment in the email), does it have the correct name.

    Please provide WBXML log for such an attachment being synced to Outlook.

    Also the latest Z-Push version is 2.5.0.

    Manfred



  • Hello Felix, Hello Manfred,

    thank you very much for your answers.

    I updated to z-push 2.5.0, thanks for the hint.
    It is hard to reproduce, because i am not sure yet, what is triggering this issue(count of attachments, filetypes, or specific names … ), and at all i am using most of the time the awesome deskapp/ webapp, and there everything works fine.

    But anyway i think also for others it would be great to solve the bug.

    I have opened a ticket, in ubuntu launchpad, but i think this will take a while, maybe we will find a solution here quicker. :)

    So in the next step i will try to reproduce and capture logs in debug mode, to post them here.

    Further i wanted to mention what a great projekt Kopano is, and that you guys are doing a awesome job! Keep up the great work.

    Best regards



  • Hi @Chris2,
    what happened to your “old corrupted” attachments, are they still in the “unnamed attachment.dat” style? I’m asking because after upgrading to Kopano 8.7.82 and Z-Push 2.5 we got the same strange renaming with some kind of mails. (luckily I was able to repdoruce this). After manually upgrading libvmime it seems to be ok for new incoming mails. But the old corrupted ones are still in the “unnamed attachment.dat” style. Even after full resync.

    By the way, we are using the official Kopano final repo for Ubuntu 16.04


  • Kopano

    @Pax said in Unbenannte Anlage XXXX.Dateiendung/ unnamed attachment.file - when using Outlook:

    8.7.82
    By the way, we are using the official Kopano final repo for Ubuntu 16.04

    These are quite contradicting statements. 8.7.82 is not the version you would get from the final repository. This would be 8.7.3 at this point in time.



  • @fbartels said in Unbenannte Anlage XXXX.Dateiendung/ unnamed attachment.file - when using Outlook:

    These are quite contradicting statements. 8.7.82 is not the version you would get from the final repository. This would be 8.7.3 at this point in time.

    Sorry my fault. Kopano Core is at 8.7.3 (as stated from kopano-admin -V)
    I installed the libvmime from the https://download.kopano.io/community/ which is at version 8.7.82


  • Kopano

    Hi @Pax,

    I would not really recommend mixing packages from these different releases as this might have other side effect. Since you say you get these unnamed attachments with our supported release can you get in touch with our support so that they can have a closer look?


Log in to reply