Delete new group from everyone group kopano



  • Hi

    I have made 2 new groups and i would delete these from everyone’s group otherwise the user comes with 2 times, when sent a mail to everyone, can this be done and how
    cb


  • Kopano

    Hi @cbnidk,

    It’s not possible to exclude entries from the everyone group.

    The alternative would be to hide the everyone group and define your own “all” group.



  • @fbartels said in Delete new group from everyone group kopano:

    to hide the everyone group

    Hi

    How can I hide the everyone group?, it is a ok solution for me

    I have found the solutiom on google

    server.cfg
    hide_everyone = yes
    If this option is set to ‘yes’, the internal group Everyone (which always contains all users) will be hidden from the Global Addressbook. Thus, users will not be able to send e-mail to this group anymore, and also will not be able to set access rights on folders for this group. Administrators will still be able to see and use the group.
    Default: no

    Thank you for your quick answer

    cb



  • hi

    The everyone group is only gone in webapp it is not gone in outlook
    and I have make a sync of Global Addressbook to outlook
    /usr/share/z-push/tools/gab-sync# ./gab-sync.php -a sync
    but in outlook the everyone group is still there
    if I make a sync I can see 17 itens is sync but it only have to be 16, so the sync don’t take away the everyone group

    in outlook I use KOE to see Global Addressbook
    how can I fix this?

    cb


  • Kopano

    @cbnidk I would not exclude the possibility that the hide everyone option is not honoured by the gabsync script.



  • This post is deleted!


  • @fbartels

    Hi

    The problem is that adress book don’t get hidden if I set it to be hidden in server.cfg
    it is only my own group that I can get hidden adress book in by ldap
    I think this is a bug
    it gets hidden i webapp but not in outlook
    my own group teknik_group is hidden in webapp and outlook this is working

    root@kopano:/# kopano-cli --group everyone
    Name: everyone
    Email address:
    Address Book: visible
    Send-as:
    Users (14):

    User Full Name Homeserver
    root@kopano:/# kopano-cli --group teknik_group
    Name: teknik_group
    Email address:
    Address Book: hidden
    Send-as:
    Users (3):
    User Full Name Homeserver

    cb
    kd
    pm


  • Kopano

    Hi @cbnidk,

    yes there seems to be indeed a mixup with the output of kopano-cli. Everyone is a “special” group and its probably looking up the visibility status of it in a different value. I have created https://jira.kopano.io/browse/KC-1494 to look into this at a later point.

    But since the group is not shown in WebApp the setting itself continues to work.


Log in to reply