Unable to change loginname from username to e-mail using OpenLDAP



  • I’m trying to change the loginname from username to emailaddress.
    It’s a multi tenant installation with no problems so far.

    Settings are:
    /etc/kopano/server.cfg

    sync_gab_realtime = yes 
    user_safe_mode = no
    

    /usr/share/kopano/ldap.openldap.cfg (which is included in /etc/kopano/ldap.cfg)

    ldap_loginname_attribute = mail
    

    used version:
    Debian GNU/Linux buster/sid
    kopano-server 8.7.0

    Details:

    Apr  1 18:35:01 mailbox01 kopano-server[717]: Accepted incoming connection from file:///var/run/kopano/server.sock
    Apr  1 18:35:01 mailbox01 slapd[482]: <= mdb_equality_candidates: (ou) not indexed
    Apr  1 18:35:01 mailbox01 slapd[482]: <= mdb_equality_candidates: (mail) not indexed
    Apr  1 18:35:01 mailbox01 kopano-server[717]: Authentication by plugin failed for user "heinz.horst@test.tld": Trying to authenticate failed: heinz.horst not found in LDAP; username = heinz.horst
    

    Any idea?
    regards
    Robert


  • Kopano

    @Robert,

    This should just work, the best thing you can do however is copy this line(ldap_loginname_attribute = mail
    ) to /etc/kopano/ldap.cfg
    The ldap.openldap.cfg in /usr/share/kopano will change with every update of Kopano

    What does kopano-admin -l say it should display the email address there as well.



  • Hi robing,

    unfortunately it doesn’t.
    I’ve already changed the ldap_loginname_attribute = mail
    to /etc/kopano/ldap.cfg

    kopano-admin -l shows the user for that domain
    25a69139-e4f7-4023-a4fa-8f23091b35ee-grafik.png

    As soon as I switch back to ldap_loginname_attribute = uid and reload the service kopano-server I can login as heinz.horst without any problems.

    regards
    Robert


  • Kopano

    Did you change the the loginname_format value in the server.cfg in /etc/kopano ?
    it should be set on loginname_format = %u



  • Hi robing,

    this I found out a few minutes before your post (because I found new created users with usernames like heinz.horst@test.tld@test.tld) .

    First: All is working fine now!

    For all others - my settings are now:

    /etc/kopano/server.cfg
    loginname_format =%u
    sync_gab_realtime = yes
    user_safe_mode = no

    /etc/kopano/ldap.cfg
    ldap_loginname_attribute = mail

    After all, RESTART the service kopano-server - a reload seems to be not enough!

    Thank you robing for your hints!

    regards
    Robert


Log in to reply