php7-mapi not found



  • Hi - I’ve set up a new kopano core 8.4.0~415_96.1 install on an ubuntu 16.04 VPS (looking to move across from an old zarafa setup) and have run into an issue.
    I get the “Not Found: PHP mapi extension not found” message when browsing to the webapp URL. I installed the php7-mapi that came with kopano core but I don’t think it has been enabled yet - it doesn’t show up under phpinfo either… Could some kindly soul please explain in small words how to do so?
    Much obliged!

    Karl


  • Kopano

    Hi Karl,

    Perhaps you can try to reconfigure php-mapi:
    dpkg-reconfigure php7-mapi and restart apache.



  • Hi Marty - thanks for an amazingly quick reply!
    I tried reconfiguring and received the following before it completed:
    “php5-mapi: using mods-available directory”
    Assume this means it isn’t showing as an available module? I’ve checked using “dpkg-l | grep php” and don’t see anything referencing php5. Also listing /etc/apache2/mods-available and mods-enabled both show php7.0 but not anything for php5.



  • Please consider this solved - performed an apt-get purge on all php5 packages then reconfigured and webapp now loads.
    Blind fumbling for the win!
    Thanks for help Marty :)


  • Kopano

    Glad to hear :)


Log in to reply