kopano-webapp keeps enable-ing even after disabled it.



  • Hai,

    Every kopano upgrade kopano-webapp.conf is killing my apache settings.

    First of all, why are “SETTINGS” enabled as SITE !
    and why is kopano overrulling my setings when i DISABLED the SITE kopano-webapp.
    It’s not a site. !!

    if i run a2dissite kopano-webapp, its disabled.
    At upgrade kopano should respect this setting.
    This is a bug.

    in addition.

    I dont want to run webapp on all my hosts and just on 1 vhost.
    The current config and setup overrulles the option to run it on 1 vhost.

    and really, can someone explain to my why a config us setup as site?
    Please use a2enconf not a2ensite.



  • While I agree that storing a configuration as a site definition…
    Why don’t you just avoid installing webapp on hosts where you don’t want it to run?



  • You tell my how.

    If i have 10 vhosts on 1 server and kopano-webapp installs or upgrades… and that is my main problem… the upgrade, then webapp is enabled again after the upgrade as site.

    So if anyone can tell me how i can stop the webapp from enable-ing after every upgrade, without myself having to run a2dissite kopano-webapp

    because i dont know how. :-(



  • Sorry, I misunderstood this initially. Got confused by the mixing of terms “hosts” and “vhosts”.
    Indeed, what you write is true, and potentially a problem. I actually have two vhosts on my webapp server, and only one of them is supposed to expose webapp. As my user community is very small, I don’t care too much about this, but I understand that it is a real problem with 10 vhosts.
    BTW, I added a redirect from the vhost that should not offer webapp to the correct link. I know that this doesn’t solve the original issue (which I understand now as being real), but it might be a workaround until this gets fixed by Kopano…



  • best solution i’ve found for now.

    # copy the kopano-webapp.conf
    cp /etc/apache2/sites-available/kopano-webapp.conf  /etc/apache2/conf-available/kopano-webapp.conf 
    # empty the fil in sites-available 
    > /etc/apache2/sites-available/kopano-webapp.conf  
    

    upgrade kopano-webapp 3.5.2 to kopano-webapp 3.5.3.2146+1193.1
    works fine now.

    and include /etc/apache2/conf-available/kopano-webapp.conf
    in you vhost.

    still this is very annoying…

    Preparing to unpack .../15-kopano-webapp_3.5.3.2146+1193.1_all.deb ...
    Site kopano-webapp already disabled
    Setting up kopano-webapp (3.5.3.2146+1193.1) …
    ..
    Enabling site kopano-webapp.
    To activate the new configuration, you need to run:
      systemctl reload apache2
    Setting up kopano-python-utils (8.7.80.578.51202649e-0+94.1) ...
    

    At least is not messing up my webserver config anymore.

    and if its possible to detect : Site kopano-webapp already disabled
    Why not respect the setting of the user!



  • Still happens with :

    Preparing to unpack …/13-kopano-webapp_3.5.3.2149+1194.1_all.deb …
    Site kopano-webapp disabled.

    To activate the new configuration, you need to run:
      systemctl reload apache2
    Unpacking kopano-webapp (3.5.3.2149+1194.1) over (3.5.3.2146+1193.1) ...
    
    Installing new version of config file /etc/kopano/webapp/config.php ...
    Enabling site kopano-webapp.
    To activate the new configuration, you need to run:
      systemctl reload apache2
    

    But i can say that a empty-ing the webapp.conf works great.
    Its not messing up my vhosts sites anymore.


  • Kopano

    @thctlo

    Glad to hear you found a workaround.

    We’re planning to make a separate package for e.g. configs: https://jira.kopano.io/browse/KW-882
    That will also solve part of your issues.

    The conf-enabled related issue will be tackled here: https://jira.kopano.io/browse/KW-2998



  • YES !!! that is a great idea, beter late then never.
    Thank you for the notice, i’ll be the first to test it out :-)