Feature request - Header Message-Id do not contain recommended domain name



  • The antispam software is giving email sent from WebApp an extra 0.5 score because the Message-Id line do not contain a correct domain name.

    According to RFC 5322
    Note: As with addr-spec, a liberal syntax is given for the right-hand side of the “@” in a msg-id. However, later in this section, the use of a domain for the right-hand side of the “@” is RECOMMENDED.

    In version WebApp 3.5.1 kopano is using the domain “@kopano”. As example gmail application from a android mobile phone is using “@email.android.com”. My suggestion is to use “@kopano.io” or “@webapp.kopano.io” when sending from WebApp.


  • Kopano

    Hi @Blinkiz ,

    on the first look this looks like a configuration mistake on your side. I just sent a mail from my private system and looked at the header and the Message-Id has the fqdn of my kopano system in the id. e.g. Message-Id: <kcis.05CAFFCA2AAC41769BC9BDF80920D1D2@my.system.de>



  • Thanks for the update fbartels. As you say, I do have in /etc/hostname the value “kopano.lxd”. Nothing in /etc/hosts.

    In my opinion WebApp should not try to figure out what the right domain name is. We are going in the direction that application will be running in containers like docker or LXC which complicates access to the right domain by asking localhost. It does not appear that other client software are trying to do this. Maybe opportunity to simplify code?


  • Kopano

    I can’t tell you the configuration option from the top of my head. it is working like I showed you on an old Ubuntu 14.04 system, but seems different on a newer system with Debian 9.


  • Kopano

    looking into this a bit further this looks like a regression in vmime (delivered since ~8.6.5(. I have created https://jira.kopano.io/browse/KC-1393


Log in to reply