A new form of the old german ü / ö Problem?



  • i am working with KOPANO in a Debian 9 virtual Machine. I am using the community edition with only a few items: Core Vers.: 8.7.80-468 and Webapp Vers.: 3.5.2.2098+1157.1. The base-OS is the aktual updatet Deb 9.6 with Mysql 10, Apache 2.4, z-Push 2.4.5 etc…
    The primar language is German, everything ( believe me ) in every part of the installation ist set to “de_DE.UTF-8”. In Outlook connected with MAPI (over the old ZARAFA-Client) and also connected via Z-PUSH / ActiveSync every user has “German Stores with Umlaut”. In the same way, there ist no problem with the smartphones. Everything ist in the right way and in german.

    But in Webapp or Deskapp we got to see the “old german umlaute problem”. Perhaps this may a new form of it. In a naked new install the first login in webapp / deskapp looks fine like this:

    0_1547670180592_Bildschirmfoto 2019-01-16 um 20.32.10.jpg

    Nothing changed, only a new login was made and it looks like this:

    0_1547670283023_Bildschirmfoto 2019-01-16 um 20.32.57.jpg

    As you see “Entwürfe” changed to “Entw?rfe” and so on. There is no problem in the content. ü / ö are normaly visible in mail and files. There is a script localized-folder.ph, that may help. But in this constellation not. — This is no problem of the sql-database ( the lang collotion is UTF8mb4). If you query the items direct by sql, then they are in german with “ü/ö”.

    Any hints by the forum? It’s not the world, but scary!

    ZARA / KOPA


  • Kopano

    Hi @zara-kopa ,

    something similar has already been discussed in https://forum.kopano.io/topic/1297/core-8-6-80-621-german-umlauts-broken-in-the-subject-line-of-sent-mails. For me this is working as expected, though.

    This issue was in the past always caused by the webserver/php not running with a unicode capable locale. The localize folder script won’t help you, since its just a display issue in the webserver.



  • Hi Felix

    i solved my problem! It was made by my own. All Ü’s and Ö’s are stable back again.
    Shamefully the reason was a miss-configuration of the Apache server! No php Problem.
    The error results out of a not enabled “javascript-common.conf” and some enabled mods with conflicts.

    Herzlichen Dank


Log in to reply