-solved- problem to send e-mails with big copy and pasted pictures



  • Hi@all
    now I got a problem during sending e-mails with big copy and pasted pictures.
    With smaller pictures there are no problems. I tested it with some Microsoft Snipping Tool images.
    Maybe there is a timeout?
    Some informations:
    Ubuntu 16.04 - 64 Bit
    core-8.4.0-344_74
    WebApp 3.3.0.596-427.1

    After pressing the “send” button, it looks like it’s working. After a few seconds the hourglas stops working without sending the message. While trying to resend or save, nothing happens. Sending and saving of this message isn’t possible anymore.

    Please … check and confirm …



  • There is a problem uploading large attachments too. One pdf with 4 Mb fails without errors, the hourglas bar works also without finishing.


  • Translator

    there are settings in PHP (if I remember correctly) where you can increase limits. I am not in front of the config files now therefore I can’t remember exactly but there are. I solved it some time ago.



  • thanks for the good point @ mcostan.
    Unfortunately the problem isn’t solved after i had changed the php.ini values. from 2 MB to 500.

    I got another approach, as I opened the Kopano webapp via http://kopano:8000/webapp (cause https leads through nginx internal proxy) there is no problem with attachments and picture-paste.
    If you use the webmeetings, you need the nginx proxy.

    Any ideas?


  • Translator

    I am afraid I do not have access to the configuration of Kopano right now (I cannot access our system from here) but I did configure NGINX for web meetings and webapp via apache (on ubuntu) and fixed the issue of attachments… So it can be done.


  • Translator

    Also have a look at /etc/postfix/main.cf (if you use postfix), the line that says message_size_limit



  • Hi klausade,
    the message_size_limit of postfix isn’t the problem.
    It’s changed and without nginx everything works fine.

    thanks

    in nginx I used the example configuration from the documentation:
    [https://documentation.kopano.io/web_meetings_manual/configuration.html]
    (https://documentation.kopano.io/web_meetings_manual/configuration.html)

    proxy_buffering on;
    proxy_ignore_client_abort off;
    proxy_redirect off;
    proxy_connect_timeout 90;
    proxy_send_timeout 90;
    proxy_read_timeout 90;
    proxy_buffer_size 4k;
    proxy_buffers 4 32k;
    proxy_busy_buffers_size 64k;
    proxy_temp_file_write_size 64k;
    proxy_next_upstream error timeout invalid_header http_502 http_503 http_504;



  • Solved ;)

    include in the /etc/nginx/nginx.conf
    client_max_body_size 50M;
    systemctl restart nginx

    …and it works!


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.