Setting the send as address for public folders

Hello,

I’ve been using Zarafa/Kopano for many years but now I am stuck on a problem and can’t find any information on the internet about it.

I have a problem with setting the send as address on a public folder with the kopano outlook extension. After a recent update of the KOE an info message appears when clicking on any public folder within the koe shared folders dialogue: “Unable to determine the send-as email address for the folder. Send-as will only work if you specify the email address manually.”

There is also a new field showing up beneath every public folder within the shared folders window: “Send as address”. For each public folder (there are about 300) the field is empty. So there is not a single send-as-address set for any of the public folders.

I cannot save the dialogie anymore. It forces me to input a send-as-address for each of the 300+ public folders. I swallowed the pill and manually entered those addresses because I could not find a way to do this via the command line and then I hit the “Apply” button. But it won’t let me save then either because there then appears a new error message: “You are trying to open many additional folders. Having many shared folders open can impact the stability of Outlook. When working with many shared folders its recommended to take a look at Kopano WebApp/DeskApp instead.”

So my questions are as follow:

a) Is there a way outside of the koe shared folders dialogue to set the send-as-address for a public folder? Preferably via the command line on the server.

b) Is there a way to disable this necessity as I do not plan on using this feature?

c) Is there a way to disable the public folder limit and due to that preventing the second error message from showing up?

Every little piece of help is welcome as I am really stuck and cannot add or modify any shared objects within koe anymore.

Thank you in advance,

Tobias Burkard

Hi Tobias,

@gsa said in Setting the send as address for public folders:

So my questions are as follow:

a) Is there a way outside of the koe shared folders dialogue to set the send-as-address for a public folder? Preferably via the command line on the server.

As far as I know it’s not possible.

@gsa said in Setting the send as address for public folders:

b) Is there a way to disable this necessity as I do not plan on using this feature?

If you mean disabling sendasowner, then go to Kopano ribbon, click Kopano ribbon in Outlook, then debug, scroll to Features->SendAs, click the triangle next to “SendAs” to open the option list and set the value of SendAsOwner to false. That should prevent the dialog from popping up every time you start Outlook.

@gsa said in Setting the send as address for public folders:

c) Is there a way to disable the public folder limit and due to that preventing the second error message from showing up?

As far as I know it’s not possible to disable it. It’s possible to set a higher value for the warning though. Click Kopano ribbon in Outlook, then debug, scroll to Features->SharedFolders, click the triangle next to “SharedFolders” to open the option list and set the value of MaxFolderCount to a higher value than your shared folders.
However if you have so many shared folders opened and need them all, you should consider using Webapp or DeskApp.

Manfred

@Manfred
Hi Manfred,
this obviosly doesnt work. If I disalbe sendas Feature (as in b)) nothing happens and still after restarting Outlook I am asked for the send-as for every new folder I’ll pick up.
There should be a way to manage such things globaly (aka GPO). As I can see, setting the featur to disable writes something to the HKCU registry, so it should be possible to have som ADMX files to import in PolicyDefinition and set things for all users:
Exporting this looks like:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Kopano\Kopano OL Extension\SendAs]
@="-SendAsOwner,-"

Can you please provide a correct setting and perhaps a full list of possibilities (most common used) wich can be used in this HKCU tree?
Thank you!
Regards, Sebastian

Hi Sebastian,

@segro said in Setting the send as address for public folders:

@Manfred
Hi Manfred,
this obviosly doesnt work. If I disalbe sendas Feature (as in b)) nothing happens and still after restarting Outlook I am asked for the send-as for every new folder I’ll pick up.
There should be a way to manage such things globaly (aka GPO). As I can see, setting the featur to disable writes something to the HKCU registry, so it should be possible to have som ADMX files to import in PolicyDefinition and set things for all users:
Exporting this looks like:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Kopano\Kopano OL Extension\SendAs]
@="-SendAsOwner,-"

I’m not a KOE developer nor I use Outlook or Windows daily, so I responded to my best knowledge. The setting I’ve sent you worked in my tests.

@segro said in Setting the send as address for public folders:

Can you please provide a correct setting and perhaps a full list of possibilities (most common used) wich can be used in this HKCU tree?
Thank you!
Regards, Sebastian

There is an option to completely disable SendAs by setting Enable to false.

I don’t have the list of the registry keys.

Manfred

@segro said in Setting the send as address for public folders:

There should be a way to manage such things globaly (aka GPO)

Koe is not really intended for large scale deployments (here you should prefer DeskApp/WebApp) hence we have not implemented support for GPO. The thing you could do though is:

There is a “plugindebugger.exe” in the program dir. There you have all possible options listed along with a small description text. When comparing registry settings before and after you know what to transplant to other system.

Back to your original topic: your gab does not seem to be synced, hence koe cannot look up the address for the folder and is asking you for manual entry.

@fbartels
Hi Felix,
thank you for your hints, I’ll try that with plugindebugger.

But a little misunderstanding:
My Public Folders don’t have any “send-as” addresses, they are just there for Project-Folders and I never want to send-as "project-XY-Customer-Z@mydomain.com" and my GAB sync ist ok.

So an option to totaly disable "send-as"Feature for Public-Folders (not for shared Mailboxes) would be nice

Send-as can only be disabled “globally”, the feature does/can not make a distinction from where a shared folder is opened. But you can decide if you want to use this functionality when opening a shared folder.

Afair the entered email address will be inherited by subfolders of the current folder, I do not remember if the same is true for disabling sendas. the limit can also be influenced from the plugindebugger (but it’s of course adviced to limit folders instead of raising the limit).