z-push "Please send authorisation information"



  • Hello,

    since a few weeks i try to get a working z-push configuration.

    I can install z-push and the imap-backend and the browser-login is fine, so that i get the “GET NOT SUPPORTED” in the browser. then if i add an account on my iphone it gets the mails from the server. now if i want to move or delete a mail, it gives me an error.

    i checked the logs (with xbml) and the only error all the time i find is :

    [FATAL] [#unknown] Exception: (AuthenticationRequiredException) - Access denied. Please send authorisation information
    

    i made fresh install with debian/apache and debian/nginx. both tried with and without php-fpm.
    everytime the same problem. i read about lost auth header but in the logs i only have sometimes the problem.
    it can get the mails from the server but i can’t move it.

    anyone have some help for me ?
    am i the only person with this problem ? since 4 weeks i search and try everyday.

    thanks a lot and greetings
    Patrick


  • Kopano

    Hi Patrick,

    did you check the webserver’s logs for Unauthorized errors?

    Does it happen on every move/delete? Do you have a proxy or load balancer in front of your Z-Push server? Did you install using Z-Push repositories? What mods have you enabled for apache/nginx? Are you using a self-signed certificate?

    Manfred



  • Hello Manfred,

    thank you for your answer.
    It happens on every delete. if i move it moves to the new place and can’t be deleted on the old place, so at the end there are two duplicate mails.

    i tried it with and without certificate. same problem.
    here is are two parts of an actual log, sometimes if found “User is authenticated” and sometimes it is not possible.

    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] -------- Start
    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] cmd='Ping' devType='iPhone' devId='bn1lc7rr0t0ddecdat4m3ote7o' getUser='info@abc-def.de' from='89.245.46.5' version='2.4.5+0-0' method='POST'
    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] Used timezone 'Europe/Berlin'
    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] Request::ProcessHeaders() ASVersion: 14.0
    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] ZPush::CommandNeedsProvisioning(18): false
    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] ZPush::CommandNeedsAuthentication(18): true
    16/11/2018 18:25:49 [31776] [DEBUG] [info@abc-def.de] BackendIMAP->Logon(): User 'info@abc-def.de' is authenticated on '{localhost:993/imap/ssl/norsh/novalidate-cert}'
    

    and here :

    16/11/2018 18:25:49 [31776] [DEBUG] [#info@abc-def.de] -------- Start
    16/11/2018 18:25:49 [31776] [DEBUG] [#info@abc-def.de] cmd='Ping' devType='iPhone' devId='bn1lc7rr0t0ddecdat4m3ote7o' getUser='info@abc-def.de' from='89.245.46.5' version='2.4.5+0-0' method='POST'
    16/11/2018 18:25:49 [31776] [ INFO] [#info@abc-def.de] AuthenticationRequiredException: Access denied. Please send authorisation information - code: 0 - file: /usr/share/z-push/index.php:56
    16/11/2018 18:25:49 [31776] [ INFO] [#info@abc-def.de] User-agent: 'unknown'
    16/11/2018 18:25:49 [31776] [FATAL] [#info@abc-def.de] Exception: (AuthenticationRequiredException) - Access denied. Please send authorisation information
    

    i installed z-push from repo like descriped in the wiki, but a few days ago i manually downloaded z-push and installed with same problem. no proxy or load balancer, only a fresh “minium” install from debian9/apache2 and debian9/nginx.

    maybe i have to say that i use vServer (from server4you.de) ?


  • Kopano

    Hi Patrick,

    the logs you’ve posted are from Ping command. Deletion doesn’t happen on Ping, it happens on Sync.

    Where did you download Z-Push manually from?

    I’m not familiar with vServer nor with server4you.de and their infrastructure. Did you install your own IMAP server?

    Manfred


Log in to reply