DeskApp 2.0 final available

  • Kopano

    DeskApp 2.0 is synchronized to the final directory today

    • In this release, we support opening of EML files on your Desktop with DeskApp.
      This feature requires WebApp 3.4.22 and up.
    • We’ve also upgraded the backend to Chromium 69 and Node v10.11.0
    • Development builds are no longer available. The development console can be accessed in the normal builds via F12 (Windows + Linux) or Command + Option + i (Mac OS)

    A few issues came to light after the pre-final release related to KDE. Those are all solved.

    The complete changelog can be found here.

    Updating can be done through the repositories, packages can be downloaded from the portal or from the download server. For community members, nightly packages are available here.

  • @marty: Just double checked it, but unfortunatly the desktopnotification disappears again, if you untick “autohide”. For me that worked before the Upgrade.

    Seems like the autohide is not reacting, no matter what you set. If I set it to 28000 sec, it makes no difference. The notification disappears after about 20sec.

    You can see the program-versions in the signature.

  • @marty: can you reproduce this behaviour? It is strange, because the prerelease worked… :-/

  • Kopano

    @mcdaniels No works for me. Should be the same version.

  • Current DeskApp version is: 2.0.31

  • @WalterHof: Sorry mistake in signature: It is the 2.0.31, but it does not work…

    @marty so you use the same version than me?

  • Kopano

    The fix is not in DeskApp or WebApp code.
    Check if you have this fix in your Desktop notifications plugin:

  • @marty: ok… uh, that is really looking ugly @ nano @ server…
    one moment please. It also looks ugly @Notepad++ … I will have to go line by line…

    I still wonder why it worked a few days ago ;-)

  • @marty: none of the red or green lines are in my /usr/share/kopano-webapp/plugin/desktopnotification/js/desktopnotifications.js file. (if I am looking at the correct path)

    If you are interested in the js (Self signed SSL-cert):
    Password: !12kopano34#

  • Kopano

    @mcdaniels That is different that the file found in the package in the final directory. So double check the version you are using. Perhaps do a reinstall if needed.

    Btw, would also be useful to add your server OS in your signature.

  • @marty: Reinstall the plugin? So, a really dumb question: Where do I get the latest version of the plugin?

    I consider via the repos:


    just “purged” the plugin via apt-get and reinstalled it (restarted Apache).

    Not working… (the js file stays the same).

  • Kopano

    @mcdaniels It’s in the webapp repository.

  • @marty: yes it is coming from here : ./ Packages

    as said before just reinstalled it. after purging. JS stays the same… I am out of ideas now.

    BTW. the .js is also the same on my other installation. (community-edition-server)

  • Kopano

    @mcdaniels Yes that’s fine. I checked the deb and it is a different file than the one you linked, so look for the issue there.

  • @marty: Hm, in my opinion, the files are exactly the same.

    I just extracted the deb (kopano-webapp-plugin-desktopnotifications.deb from the repos) and opened it /tmp/xxx/usr/share/kopano-webapp/plugins/desktopnotifications/js/desktopnotifications.js

    If I look at my uploaded file they are the same.

    EDIT: Hm, I have changed nothing @the server but finally tried the V1.9.0 (resettet all / new profile) of the deskapp and it suddenly worked. After deinstalling 1.9.0 and reinstalling deskapp 2.0 it still works now. No idea why, but it is ok now… Is there some kind of cache in the deskapp?

    Update: Another PC is not behaving like that (settings are ignored).

  • I think I got it!

    The problem seems to be related to the c:<username>\Appdata\Local\Kopano DeskApp Data.

    First I installed the DeskApp 2.0 as “update” - the 1.9.0 was installed. (reminder not working)
    Then I deinstalled the DeskApp 2.0 - Installed the 1.9.0 again (incompatibility with profile), created a new profile (reminder not working)

    My last try was, to uninstall the DeskApp, then completly remove (delete) the appdatafolder of kopano (see above) and reinstall the DeskApp again.

    Now, the reminders are working as expected and are reacting to the settings you choose.

  • Kopano

    Great that it’s working for you, but if provided desktopnotification.js via your link is from your server, then that file was not up to date.

    Left is the latest,
    right is yours.

     sdiff desktopnotifications.js desktopnotifications_forum.js
    Ext.namespace("Zarafa.plugins.desktopnotifications");Zarafa.p	Ext.namespace("Zarafa.plugins.desktopnotifications");Zarafa.p
    Ext.namespace("Zarafa.plugins.desktopnotifications.js");	Ext.namespace("Zarafa.plugins.desktopnotifications.js");
    Zarafa.plugins.desktopnotifications.js.DesktopNotification=fu |	Zarafa.plugins.desktopnotifications.js.DesktopNotification=fu
    authorize:function(a){if(this.supports()){var b=Ext.isFunctio |	Ext.isFunction(b)?function(a){var c="granted";a&&(c=a);b.appl
    1E3*container.getSettingsModel().get("zarafa/v1/plugins/deskt |	1E3*container.getSettingsModel().get("zarafa/v1/plugins/deskt
    else console.log("Browser doesn't support notifications")}}}(	else console.log("Browser doesn't support notifications")}}}(
    Zarafa.plugins.desktopnotifications.DesktopNotificationsPlugi	Zarafa.plugins.desktopnotifications.DesktopNotificationsPlugi
    if(!Ext.isIE)Zarafa.onReady(function(){container.registerPlug |	Zarafa.onReady(function(){container.registerPlugin(new Zarafa
    Zarafa.plugins.desktopnotifications.js.DesktopNotifier=Ext.ex	Zarafa.plugins.desktopnotifications.js.DesktopNotifier=Ext.ex
    arguments)}});Zarafa.onReady(function(){container.getNotifier	arguments)}});Zarafa.onReady(function(){container.getNotifier
    Zarafa.plugins.desktopnotifications.js.settings.SettingsNotif	Zarafa.plugins.desktopnotifications.js.settings.SettingsNotif
    a)}});Ext.reg("zarafa.settingsdesktopnotificationscategory",Z	a)}});Ext.reg("zarafa.settingsdesktopnotificationscategory",Z
    Zarafa.plugins.desktopnotifications.js.settings.SettingsNotif	Zarafa.plugins.desktopnotifications.js.settings.SettingsNotif
    border:!1,autoHeight:!0,items:[{xtype:"displayfield",hideLabe |	border:!1,autoHeight:!0,items:[{xtype:"displayfield",hideLabe
    handler:this.onChangeCheckbox,scope:this,hideLabel:!0,ref:".. |	"Enable desktop notifications for new mail"),name:"zarafa/v1/
    labelWidth:300,combineErrors:!1,items:[{xtype:"checkbox",labe |	fieldLabel:dgettext("plugin_desktopnotifications","{A} Autohi
    allowDecimals:!1,allowNegative:!1,listeners:{change:this.onFi |	ref:"../../autoHideTimeSpinner",incrementValue:1,defaultValue
    update:function(a){this.model=a;var b=Zarafa.plugins.desktopn |	c&&this.model.set(,c);this.update(this.model)}},update:
    this.autoHideBox.setValue(a);a=this.model.get(this.autoHideTi |	a=a.get(;this.autoHideBox.setValue(a);a
    							      >	Ext.reg("zarafa.settingsdesktopnotificationswidget",

    Can you report DesktopNotifications issues in next time?

  • @marty: thanks for you investigation. and sorry for not posting in the plugins-section. Perhaps an admin can move the issue to this forum?

Log in to reply