kopano out of the office not working



  • Hi all,

    Kopano out of the office is not working.

    • if i enable it in webapp no mail is send to the mailadres that is sending me an email.

    I also noticed that when i enable oof on the terminal it is not enabled in the webapp

    i use the follwing command:

    kopano-set-oof --user Chris --mode 1 --subject 'op vakantie' --message /home/temp.txt --from "2018-11-02 21:00" --until "2018-11-03 21:00"
    

    No oof message is send. And in webapp it shows as disabled. Even if i enable it in webapp no message is send to anyone that is sending me an email.


  • Kopano

    Hi @ckruijntjens ,

    the process that is responsible for sending out the out of office message is the kopano-dagent. Therefore you should be able to find a clue to the failure in its logging.

    And as usual some version information would be nice. Which version are you currently running? On which version did you initially notice this?



  • @fbartels

    I use the latest build. now is the first time i want to use this option.

    Name        : kopano-dagent
    Arch        : x86_64
    Version     : 8.7.80.27
    Release     : 22.1
    Size        : 336 k
    Repo        : installed
    From repo   : kopano
    Summary     : E-Mail Delivery Agent for the Kopano platform
    URL         : https://kopano.io/
    License     : AGPL-3.0-only
    Description : Delivers incoming e-mail from your SMTP server to stores in the
                : Kopano server.
    
    Name        : kopano-server
    Arch        : x86_64
    Version     : 8.7.80.27
    Release     : 22.1
    Size        : 922 k
    Repo        : installed
    From repo   : kopano
    Summary     : Server component for Kopano Core
    URL         : https://kopano.io/
    License     : AGPL-3.0-only
    Description : This package provides the key component of Kopano Core, providing the
                : server to which Kopano clients connect. The server requires a MySQL
                : server to use for storage.
    
    

    In the dagent.log i see no errors. dagent is also running.

    kopano-dagent.service - Kopano Groupware Core Delivery Agent
       Loaded: loaded (/usr/lib/systemd/system/kopano-dagent.service; enabled; vendor preset: disabled)
       Active: active (running) since Sat 2018-11-03 08:16:03 CET; 2h 4min ago
         Docs: man:kopano-dagent(8)
               man:kopano-dagent.cfg(5)
     Main PID: 4602 (kopano-dagent)
       CGroup: /system.slice/kopano-dagent.service
               ├─4602 /usr/sbin/kopano-dagent -l
               └─4605 /usr/sbin/kopano-dagent -l
    
    

    If i do the command in the terminal:

    kopano-set-oof --user Chris --mode 1 --subject 'op vakantie' --message /home/temp.txt --from "2018-11-02 21:00" --until "2018-11-03 21:00"
    Out of office enabled for user 'Chris'
    Not changing subject for user 'Chris' as it was not updated
    Current subject: 'op vakantie'
    Not updating message, already matching with input file.
    
    

    I see this in webapp. (away nototification is not turned on enable)

    0_1541236972366_a942188d-2c05-4b8f-beed-855175299399-image.png

    However is i enable it in the webapp like this still no message is send out.

    0_1541237374014_9642d043-0a4e-4a1c-b389-a57bf008ee90-image.png

    Also no errors or anything in the dagent.log?


  • Kopano

    @ckruijntjens said in kopano out of the office not working:

    In the dagent.log i see no errors

    Then you probably need to raise the loglevel



  • @fbartels

    I have the level of logging on 6

    Only thing i see is

    [ debug ] Reexecing /usr/sbin/kopano-dagent

    The only other thing that is logged is that dagent starts and max lmtp threads are 20 thats it


  • Kopano

    Are you delivering mails via pipe or lmtp? In case of the first the logging is in the logging of your mta.



  • @fbartels

    hi how can i check this?


  • Kopano

    If you are delivering via lmtp or pipe? If you are using postfix, the this should be part of your main.cf. In any case this is something that you must have configured.



  • @fbartels

    indeed i am using postfix, and its configures as lmtp.


  • Kopano

    Hi @ckruijntjens ,

    I could not test this on a centos machine, as either something is broken in webapp or our machine deployment, but I did a small check on a Debian 9 machine from last, week which I updated to the latest master.

    I do have both logging in dagent.log (once configured) and out of office messages work as well.


Log in to reply