Shared Objects mapping fails

  • Hello Community,

    i’ve recently updated ZCP 7.2.5 to KC 8 with Z-Push 2.3.5 to access Outlook 2016.
    I used gab_sync.php to sync the public folders with username “SYSTEM” to the store (just like the guide said).
    Public folders are accessible and everything there is fine. - Now my Problem:
    If i try to open a calendar from another user, i just see every entry as “gebucht” (german word for “booked”), cant open, edit or create another entry. - Via webapp everything is fine, i have access and all rights are granted.

    I know that z-push delivers no grants, just the server interpret it when the action is beeing done serverside. - But i got all grants for every postbox. Postmaster/admin ftw :) - even explicit grants for this postbox wont help - not so ftw.

    Is there a way to fix it or do i need to wait for KOE 1.3.x? - and how long does this approximately take?

    Thanks in advance


  • Kopano

    Hello @Coffee_is_life ,

    It sounds a bit like you tried to open the calendar throgh the Ribbon option “Open Calendar” -> “Open shared calendar”. This will sadly only give you the free/busy data of a user, which Outlook then wrongly interprets.

    To open a shared folder or calendar you always have to use the Kopano ribbon and its option “Shared folders”.

    Is there a way to fix it or do i need to wait for KOE 1.3.x? - and how long does this approximately take?

    Kopano 1.3 final has been released a while ago.

  • Thanks for the reply @fbartels,

    the Kopano Ribbon just gives me the option to open the “public folders” and its subfolders. - This is working fine.

    But i cant see any way to open the calendar from a specific other user.
    And yes i’ve try to open it via “open calendar”-> “from adressbook”.

    i use the KOE 1.3.156 version, the “x” in my question stands for a newer version of 1.3 ;)

    //PS: i just found the option to search for a specific user in the kopano ribbon - the dropdown-list is empty, but it will find other users. (i ignored it, because i saw the public folders and nothing more)

    • solved for me - thanks :)

  • Hello again :),

    now the basic sync between users calendar etc. is working, but i’ve encountered another problem.

    Attachments that are included in a calendar item could not sync.

    “the server doenst support attachments for meetings. The attachment will be deleted and the meeting invitation/request will be send.”

    any ideas? :)


  • Kopano

    ActiveSync (up until protocol version 14) sadly does not support attachments in appointments

  • Which activeSync-Protokoll version is z-push 2.3.5+5 using (+5 caused by kopano-backend) using?
    i know they are working on AS16 implementation but no releasedate etc found.

  • Kopano

    @Coffee_is_life 14.0, as already written.

    Yes, we are still planning to support 16.0 in Z-Push, but even then its not really clear if Outlook will make use of it.

  • @Coffee_is_life said in Shared Objects mapping fails:

    //PS: i just found the option to search for a specific user in the kopano ribbon - the dropdown-list is empty, but it will find other users. (i ignored it, because i saw the public folders and nothing more)

    • solved for me - thanks :)


    I’ve also configured gabsync.conf.php with username SYSTEM, configured constant KOE_GAB_FOLDERID in z-push.conf.php accordingly, however I only have the empty drop-down list in the Kopano Ribbon, that does not find the other users. Via Kopano WebApp calender sharing works fine.

    Do I need to configure gabsync.conf.php with the username of a Kopano user instead of SYSTEM?

    Thanks, Jürgen.

    Outlook 2016
    Kopano 8.1.2 (Kopano4UCS, freshly upgraded from Zarafa 7.2.x)
    OL Extension 1.3-156
    z-push 2.3.6

  • Hi @groupnet


    define('SERVER', 'default:');
    define('USERNAME', 'SYSTEM');
    define('PASSWORD', '');
    define('HIDDEN_FOLDERNAME', 'Z-Push-KOE-GAB');

    And you need to do an initial sync:

    /<path-to-z-push>/tools/gab-sync/gab-sync.php -a sync

    if its not working, copy the output from the initial sync here.

    PS: if you dont use SYSTEM, there will be some issues - dont know the exact problem but i’ve found something in the past.


  • Hi @Coffee_is_life

    thanks for the instant reply! That’s exactly how I’ve setup the config.

    Output of ./gab-sync.php -a sync:

    Starting GAB sync to store 'SYSTEM'  on id '38c3e9df19f84862bb23e1d6bce05af93c4910000000'
    Kopano->clearAllNotCurrentChunkType: no invalid items, done!
    Kopano->setChunkData: account-10/8      Entries: 1       Size: 634 B    CRC: 8e5e4f0d64daed9403b339bca3eb1b70  -  unchanged
    Kopano->setChunkData: account-10/5      Entries: 3       Size: 1911 B   CRC: 040a36865915a7159ee5b37dd1b0e221  -  unchanged
    Kopano->setChunkData: account-10/1      Entries: 5       Size: 3221 B   CRC: 87ed7bf1b491302108d5b616e15d4a77  -  unchanged
    Kopano->setChunkData: account-10/0      Entries: 2       Size: 1315 B   CRC: beb523c03d367a81a5f4f7d80d146a55  -  unchanged
    Kopano->setChunkData: account-10/2      Entries: 3       Size: 2245 B   CRC: f415f7322851542028fc31b5641e3736  -  unchanged
    Kopano->setChunkData: account-10/7      Entries: 5       Size: 3283 B   CRC: c5e18bcae909a0e8e43a7b8090d756d1  -  unchanged
    Kopano->setChunkData: account-10/6      Entries: 2       Size: 1339 B   CRC: 0013b4a019b7267ab95b66f3394c2d71  -  unchanged
    Kopano->setChunkData: account-10/9      Entries: 1       Size: 647 B    CRC: aca3e6f47c60da255e0779ea48973939  -  unchanged
    Kopano->setChunkData: account-10/3      Entries: 1       Size: 648 B    CRC: 86c132eaec92a490179715a1e368cb69  -  unchanged
    Kopano->setChunkData: account-10/4      Entries: 1       Size: 640 B    CRC: f867fc8be6c375b01d5c9e6957b8e9eb  -  unchanged
            Items in GAB:                   24
            Total data size:                15883 B
            Avg. of items per chunk:        2.4
            Min. of items per chunk:        1
            Max. of items per chunk:        5
            Avg. of size per chunk:         1588 B
            Min. of size per chunk:         634 B
            Max. of size per chunk:         3283 B
            Configured amout of chunks:     10
            Ideal amount by entries:        5
            Ideal amount by size:           5

    Consequently, I’ve entered 38c3e9df19f84862bb23e1d6bce05af93c4910000000 in z-push.conf.php:

       define('KOE_GAB_STORE', 'SYSTEM');
        define('KOE_GAB_FOLDERID', '38c3e9df19f84862bb23e1d6bce05af93c4910000000');
        define('KOE_GAB_NAME', 'Z-Push-KOE-GAB');

    Via the Kopano OL extension I can open the public folders (eg. “Firmenkontakte”) and can add other ressources via the empty dropdown like “Service”, but even though this users exists, it says “Keine geteilten Ordner verfügbar” (No shared folders available);


  • HI again,

    i’ve had this issue aswell but forgot about it :)

    I think its the read-permission on the “Service”- Account.

    Log in via Webapp, open the whole Store (not just the inbox) - and set a read permission to the user who wants to read, or to everyone.

    After setting read-permission there should be some inbox visible :)


  • Thanks - that works! :)

Log in to reply