webapp-3.3.0.582_421 spellchecker not working

I have upgraded to the latest trunk webapp.

I am getting the following error when trying to spellcheck within an email:

Spellchecker request error: 500

In addition I am also getting:

Cannot connect to Database. Please contact your Administrator.

In settings.

All I have done is to install the latest packages and restarted apache2.

Also I am getting occasional errors like this:

The server reported an unknown error on your request.

Before the upgrade everything was working fine.

@mcostan said in webapp-3.3.0.582_421 spellchecker not working:

Cannot connect to Database. Please contact your Administrator.

You can ignore this one:

Cannot connect to Database. Please contact your Administrator.

It was due to me not configuring correctly the fetchmail plugin.

The spellchecker error remains.

The error for the spellchecker is due to this from the log files:

[Tue Apr 18 20:55:08.389174 2017] [:error] [pid 5862] [client ::1:50593] PHP Warning: include_once(/usr/share/kopano-webapp/plugins/spellchecker-languagepack-italian/php/plugin.SpellcheckerLanguagepackItalian.php): failed to open stream: No such file or directory in /usr/share/kopano-webapp/plugins/spellchecker/php/plugin.spellchecker.php on line 98, referer: https://z.xxx.com/webapp/

Hi Mcostan,

There are still some build issues we have to adjust.
In the meantime you can rename “spellchecker-languagepack-italian” to “spellchecker-languagepack-italian-it”.

This should solve the issue I think.

@marty

Indeed the error has now gone away. However, how do you select which spell checker you actually want to use? I.e. how do you spell check something in English, then you write an e-mail in say Italian and you can specify to spell-check that one in Italian only?

Do you mean multi-language spell checking? That is not possible with the spell checking plugin, but if you’re using DeskApp checkout https://jira.kopano.io/browse/KD-22

Or if you mean one email in English, another one in Italian, you can just simply enable more languages in the mail tab in settings and click on the drop down arrow in the spellchecker button located in the HTML editor.

@marty

got it thanks, I can see that if I enable different languages in webapp I can then spell check in different languages.

Looks good and great news about the Italian spelling.