DeskApp doesn't autorefresh

Hi,

The DeskApp neither WebApp doesn’t autorefresh. It’s necessary to click to get new e-mails.
Is it something related to server configuration or client configuration?

Thanks,
Paweł

@pawel That shouldn’t be the case.
By default your own store is refreshed every 30 seconds, and shared stores can be configured by the admin: https://documentation.kopano.io/webapp_admin_manual/config.html#shared-notifications-polling-time

What version are you using?

I use: kopano-server-8.6.7.0-16.1.x86_64

@pawel I meant WebApp version

Name : kopano-webapp
Arch : noarch
Version : 3.4.22.1784

In config.php I don’t have property:

// Define the polling interval in minutes for unread mail in shared stores.
define('SHARED_STORE_POLLING_INTERVAL', 15);

BTW: you mentioned that it’s refreshed each 30 seconds and the value seems to be in minutes.

@pawel

Your own store has a polling interval of 30 seconds by default and cannot be modified by a user, unless “Advanced settings” is enabled by an admin or someone modified it via the browser console.

The config option is about shared stores.

// Define the polling interval in minutes for unread mail in shared stores.
define('SHARED_STORE_POLLING_INTERVAL', 15);

This config option is added in 3.4.22. You might need to update your config.php if you’ve updated from an older version.

https://stash.kopano.io/projects/KW/repos/kopano-webapp/browse/config.php.dist#173

We see the same thing. It’s typical for WebApp to be displaying a message in the inbox and if you look up at Inbox it will say Inbox(7) or something.
It will stay this way all day, or increase to Inbox(20). You need to click on Inbox or hit refresh. Note I am using Deskapp.
WebApp: 3.4.20.1690-74.1
Kopano Core:8.6.7.0

0_1541696482308_webapp.jpg