upgrade to core-8.6.81.435, kopano-search won't start

Hey,
got these logs:

2018-10-01 16:06:59,279 - index0 - WARNING - Sync state does not exist on server (anymore); requesting new one
2018-10-01 16:17:01,579 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:07,153 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:12,158 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:17,164 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:22,166 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:27,170 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:32,174 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:37,180 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

2018-10-01 16:17:42,185 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/kopano/log.py", line 89, in log_exc
    try: yield
  File "/usr/lib/python2.7/dist-packages/kopano_search/__init__.py", line 382, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.7/dist-packages/kopano/server.py", line 736, in sync
    return _ics.sync(self, self.mapistore, importer, state, log or self.log, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.7/dist-packages/kopano/ics.py", line 244, in sync
    exporter.Config(stream, flags, importer, restriction, None, None, 0)
  File "/usr/lib/python2.7/dist-packages/MAPICore.py", line 1344, in Config
    def Config(self, *args): return _MAPICore.IExchangeExportChanges_Config(self, *args)
MAPIErrorNetworkError: MAPI error 80040115 (MAPI_E_NETWORK_ERROR)

and not able to bring the kopano-search up.
Any ideas, how to fix it?

ps

 ls -l /var/run/kopano/
total 20
-rw------- 1 kopano kopano 4 Oct  1 17:48 dagent.pid
-rw-r--r-- 1 kopano kopano 4 Oct  1 17:48 gateway.pid
-rw-r--r-- 1 kopano kopano 4 Oct  1 17:48 monitor.pid
srw-rw---- 1 kopano kopano 0 Oct  1 17:48 prio.sock
-rw-r--r-- 1 kopano kopano 5 Oct  1 17:48 server.pid
srw-rw-rw- 1 kopano kopano 0 Oct  1 17:48 server.sock
-rw------- 1 kopano kopano 4 Oct  1 17:48 spooler.pid

everything in place.
kopano-search.cfg is the default one.

Here the error-logs are slightly different:

syncid, changeid = struct.unpack('<II', _bdec(state))
error: unpack requires a string argument of length 8

(logged every 5s.), but probably related.

In contrary to @romeor description, search is running here, but finding only items existing at initial index-run or during reindex-runs. All items created afterwards obviously don’t get indexed and can’t be found.

2018-10-01 18:14:21,245 - search - WARNING - Sync state does not exist on server (anymore); requesting new one
2018-10-01 18:14:21,246 - search - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/kopano-8.6.81-py2.6.egg/kopano/log.py", line 103, in log_exc
    try: yield
  File "/usr/lib/python2.6/site-packages/kopano_search-8.6.81-py2.6.egg/kopano_search/__init__.py", line 393, in incremental_sync
    new_state = self.server.sync(importer, self.state, log=self.log)
  File "/usr/lib/python2.6/site-packages/kopano-8.6.81-py2.6.egg/kopano/server.py", line 757, in sync
    return _ics.sync(self, self.mapistore, importer, state, max_changes, window=window, begin=begin, end=end, stats=stats)
  File "/usr/lib/python2.6/site-packages/kopano-8.6.81-py2.6.egg/kopano/ics.py", line 254, in sync
    syncid, changeid = struct.unpack('<II', _bdec(state))
error: unpack requires a string argument of length 8

++umgfoin.

Hello @umgfoin and thanks for your answer.
No, search is not running:

 service kopano-search status
● kopano-search.service - Kopano Groupware Core Search Daemon
   Loaded: loaded (/lib/systemd/system/kopano-search.service; enabled)
   Active: failed (Result: exit-code) since Tue 2018-10-02 09:51:27 EEST; 977ms ago
     Docs: man:kopano-search(8)
           man:kopano-search.cfg(5)
  Process: 7328 ExecStart=/usr/sbin/kopano-search -F (code=exited, status=1/FAILURE)
 Main PID: 7328 (code=exited, status=1/FAILURE)


Oct 02 09:51:27 my-host kopano-search[7328]: from .store import Store
Oct 02 09:51:27 my-host kopano-search[7328]: File "/usr/lib/python3/dist-packages/kopano/store.py", line 65, in <module>
Oct 02 09:51:27 my-host kopano-search[7328]: from . import notification as _notification
Oct 02 09:51:27 my-host kopano-search[7328]: File "/usr/lib/python3/dist-packages/kopano/notification.py", line 32, in <module>
Oct 02 09:51:27 my-host kopano-search[7328]: from . import folder as _folder
Oct 02 09:51:27 my-host kopano-search[7328]: File "/usr/lib/python3/dist-packages/kopano/folder.py", line 92, in <module>
Oct 02 09:51:27 my-host kopano-search[7328]: _ics = sys.modules[__package__ + '.ics']
Oct 02 09:51:27 my-host kopano-search[7328]: KeyError: 'kopano.ics'
Oct 02 09:51:27 my-host systemd[1]: kopano-search.service: main process exited, code=exited, status=1/FAILURE
Oct 02 09:51:27 my-host systemd[1]: Unit kopano-search.service entered failed state.

I don’t know if this one related, but am not able to install the python3-kopano-rest package:

dpkg -i python3-kopano-rest_8.6.81.435-0+75.1_all.deb
Selecting previously unselected package python3-kopano-rest.
(Reading database ... 82969 files and directories currently installed.)
Preparing to unpack python3-kopano-rest_8.6.81.435-0+75.1_all.deb ...
Unpacking python3-kopano-rest (8.6.81.435-0+75.1) ...
dpkg: dependency problems prevent configuration of python3-kopano-rest:
 python3-kopano-rest depends on python3-jwt (>= 1.33) | kopano-python3-extras; however:
  Version of python3-jwt on system is 0.2.1-1+deb8u2.
  Package kopano-python3-extras is not installed.
 python3-kopano-rest depends on python3-ujson; however:
  Package python3-ujson is not installed.

dpkg: error processing package python3-kopano-rest (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python3-kopano-rest

Sometimes the installation error looks like this:

Unpacking python3-kopano-rest (8.6.81.435-0+75.1) ...
dpkg: dependency problems prevent configuration of python3-kopano-rest:
 python3-kopano-rest depends on python3-jwt (>= 1.33) | kopano-python3-extras; however:
  Version of python3-jwt on system is 0.2.1-1+deb8u2.
  Package kopano-python3-extras is not installed.
 python3-kopano-rest depends on python3-ujson; however:
  Package python3-ujson is not installed.

dpkg: error processing package python3-kopano-rest (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python3-kopano-rest

Like where could I get the kopano-python3-extras package, it is not available from that tar.gz from the download page.

@romeor said in upgrade to core-8.6.81.435, kopano-search won't start:

I don’t know if this one related

No, definitely not related. The python3-kopano-rest package belongs to our in development rest api. At this moment there is not much use the install it outside of development environments.

@romeor said in upgrade to core-8.6.81.435, kopano-search won't start:

where could I get the kopano-python3-extras package

I did check the public Ubuntu 18.04 repo and there the package was included. Which distribution are you using?

@fbartels
I’m using debian8 distribution and here is the list of extracted archive.

-rw-r--r-- 1 25122 users   959124 Sep 28 17:59 gsoap_2.8.62-0+2.1_amd64.deb
-rw-r--r-- 1 25122 users  2635934 Sep 28 17:59 gsoap-dbg_2.8.62-0+2.1_amd64.deb
-rw-r--r-- 1 25122 users 11279890 Sep 28 17:59 gsoap-doc_2.8.62-0+2.1_all.deb
-rw-r--r-- 1 25122 users    39170 Sep 28 17:59 kopano-backup_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    14228 Sep 28 17:59 kopano-bash-completion_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   358548 Sep 28 17:59 kopano-client_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    18196 Sep 28 17:59 kopano-common_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    41548 Sep 28 17:59 kopano-contacts_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   123886 Sep 28 17:59 kopano-dagent_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    12196 Sep 28 17:59 kopano-dbg_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   139982 Sep 28 17:59 kopano-dev_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   139032 Sep 28 17:59 kopano-gateway_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    17292 Sep 28 17:59 kopano-grapi_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   115666 Sep 28 17:59 kopano-ical_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users  7383712 Sep 28 17:59 kopano-kapid_0.6.4-0+6.1_amd64.deb
-rw-r--r-- 1 25122 users  3597100 Sep 28 17:59 kopano-konnectd_0.14.3-0+17.1_amd64.deb
-rw-r--r-- 1 25122 users    63604 Sep 28 17:59 kopano-lang_8.6.81.435-0+75.1_all.deb
-rw-r--r-- 1 25122 users    72778 Sep 28 17:59 kopano-migration-imap_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    74710 Sep 28 17:59 kopano-migration-pst_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    43704 Sep 28 17:59 kopano-monitor_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    20300 Sep 28 17:59 kopano-presence_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    42886 Sep 28 17:59 kopano-python-utils_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    43730 Sep 28 17:59 kopano-search_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   260160 Sep 28 17:59 kopano-server_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    12384 Sep 28 17:59 kopano-server-packages_8.6.81.435-0+75.1_all.deb
-rw-r--r-- 1 25122 users    20498 Sep 28 17:59 kopano-spamd_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    80026 Sep 28 17:59 kopano-spooler_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   184058 Sep 28 17:59 kopano-utils_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   724078 Sep 28 17:59 libgsoap-dbg_2.8.62-0+2.1_amd64.deb
-rw-r--r-- 1 25122 users    28516 Sep 28 17:59 libgsoap-dev_2.8.62-0+2.1_amd64.deb
-rw-r--r-- 1 25122 users   242742 Sep 28 17:59 libgsoap-kopano-2.8.62_2.8.62-0+2.1_amd64.deb
-rw-r--r-- 1 25122 users    77878 Sep 28 17:59 libjsoncpp1_1.7.2-1~bpo8+1_amd64.deb
-rw-r--r-- 1 25122 users    21956 Sep 28 17:59 libjsoncpp-dev_1.7.2-1~bpo8+1_amd64.deb
-rw-r--r-- 1 25122 users   163932 Sep 28 17:59 libjsoncpp-doc_1.7.2-1~bpo8+1_all.deb
-rw-r--r-- 1 25122 users    97716 Sep 28 17:59 libkcarchiver0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    90438 Sep 28 17:59 libkcarchivercore0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    51868 Sep 28 17:59 libkcfreebusy0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   100020 Sep 28 17:59 libkcicalmapi0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   195826 Sep 28 17:59 libkcinetmapi0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users  1533914 Sep 28 17:59 libkcoidc0_0.4.3-0+21.1_amd64.deb
-rw-r--r-- 1 25122 users     2634 Sep 28 17:59 libkcoidc-dev_0.4.3-0+21.1_all.deb
-rw-r--r-- 1 25122 users    21908 Sep 28 17:59 libkcpyplug_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    23138 Sep 28 17:59 libkcrosie0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   632594 Sep 28 17:59 libkcserver0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   234896 Sep 28 17:59 libkcsoap0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   173542 Sep 28 17:59 libkcutil0_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   167408 Sep 28 17:59 libmapi1_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users    30058 Sep 28 17:59 libs3-4_4.1.git257-0+2.2_amd64.deb
-rw-r--r-- 1 25122 users    20424 Sep 28 17:59 libs3-dev_4.1.git257-0+2.2_amd64.deb
-rw-r--r-- 1 25122 users   121190 Sep 28 17:59 libtidy5_5.1.9+3.1_amd64.deb
-rw-r--r-- 1 25122 users   115924 Sep 28 17:59 libvmime-dev_0.9.2.50+11.1_amd64.deb
-rw-r--r-- 1 25122 users  1069540 Sep 28 17:59 libvmime-kopano1_0.9.2.50+11.1_amd64.deb
-rw-r--r-- 1 25122 users   179456 Sep 28 17:59 php5-mapi_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   105172 Sep 28 17:59 python3-kopano_8.6.81.435-0+75.1_all.deb
-rw-r--r-- 1 25122 users    28274 Sep 28 17:59 python3-kopano-rest_8.6.81.435-0+75.1_all.deb
-rw-r--r-- 1 25122 users   275450 Sep 28 17:59 python3-mapi_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   217828 Sep 28 17:59 python-kopano_8.6.81.435-0+75.1_all.deb
-rw-r--r-- 1 25122 users   300378 Sep 28 17:59 python-mapi_8.6.81.435-0+75.1_amd64.deb
-rw-r--r-- 1 25122 users   114960 Sep 28 17:59 tidy-html5_5.1.9+3.1_amd64.deb
-rw-r--r-- 1 25122 users    20972 Sep 28 17:59 tidy-html5-dev_5.1.9+3.1_amd64.deb

I was not using apt repository, I’ve downloaded packages from here: https://download.kopano.io/community/core:/

Hi @romeor ,

@romeor said in upgrade to core-8.6.81.435, kopano-search won't start:

I’m using debian8

thanks, This dependency is indeed not available for Debian 8. I have created https://jira.kopano.io/browse/KC-1296 to make sure these packages are in the future not included anymore with the Debian 8 packages.

@fbartels thanks. But are they related with my problem with the search engine? Any advises to make it working again? :(

Hi @romeor,

I’ve already answered you this above:

@fbartels said in upgrade to core-8.6.81.435, kopano-search won't start:

No, definitely not related.

As for the KeyError traceback I was able to reproduce this on a testing machine and created https://jira.kopano.io/browse/KC-1297 for a dev to take a look at this.

@fbartels
thanks. Could you please update this topic when patch is released?